Re: [PATCH] mm/ksm: One function call less in __ksm_enter()

From: Kirill Tkhai
Date: Mon Jul 08 2019 - 02:34:27 EST


On 05.07.2019 17:16, Markus Elfring wrote:
> From: Markus Elfring <elfring@xxxxxxxxxxxxxxxxxxxxx>
> Date: Fri, 5 Jul 2019 16:02:26 +0200
>
> Avoid an extra function call by using a ternary operator instead of
> a conditional statement.
>
> This issue was detected by using the Coccinelle software.
>
> Signed-off-by: Markus Elfring <elfring@xxxxxxxxxxxxxxxxxxxxx>
> ---
> mm/ksm.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/mm/ksm.c b/mm/ksm.c
> index 3dc4346411e4..7934bab8ceae 100644
> --- a/mm/ksm.c
> +++ b/mm/ksm.c
> @@ -2521,10 +2521,10 @@ int __ksm_enter(struct mm_struct *mm)
> * scanning cursor, otherwise KSM pages in newly forked mms will be
> * missed: then we might as well insert at the end of the list.
> */
> - if (ksm_run & KSM_RUN_UNMERGE)
> - list_add_tail(&mm_slot->mm_list, &ksm_mm_head.mm_list);
> - else
> - list_add_tail(&mm_slot->mm_list, &ksm_scan.mm_slot->mm_list);
> + list_add_tail(&mm_slot->mm_list,
> + ksm_run & KSM_RUN_UNMERGE
> + ? &ksm_mm_head.mm_list
> + : &ksm_scan.mm_slot->mm_list);

Despite coccinelle warnings, I'm not sure this patch does not make the readability worse...

> spin_unlock(&ksm_mmlist_lock);
>
> set_bit(MMF_VM_MERGEABLE, &mm->flags);