[PATCH net-next 0/5] net: dsa: mv88e6xxx: avoid some redundant VTU operations

From: Vivien Didelot
Date: Thu Aug 01 2019 - 14:37:01 EST


The mv88e6xxx driver currently uses a mv88e6xxx_vtu_get wrapper to get a
single entry and uses a boolean to eventually initialize a fresh one.

However the fresh entry is only needed in one place and mv88e6xxx_vtu_getnext
is simple enough to call it directly. Doing so makes the code easier to read,
especially for the return code expected by switchdev to honor software VLANs.

In addition to not loading the VTU again when an entry is already correctly
programmed, this also allows to avoid programming the broadcast entries
again when updating a port's membership, from e.g. tagged to untagged.

This patch series removes the mv88e6xxx_vtu_get wrapper in favor of direct
calls to mv88e6xxx_vtu_getnext, and also renames the _mv88e6xxx_port_vlan_add
and _mv88e6xxx_port_vlan_del helpers using an old underscore prefix convention.

In case the port's membership is already correctly programmed in hardware,
the following debug message may be printed:

[ 745.989884] mv88e6085 2188000.ethernet-1:00: p4: already a member of VLAN 42

Vivien Didelot (5):
net: dsa: mv88e6xxx: lock mutex in vlan_prepare
net: dsa: mv88e6xxx: explicit entry passed to vtu_getnext
net: dsa: mv88e6xxx: call vtu_getnext directly in db load/purge
net: dsa: mv88e6xxx: call vtu_getnext directly in vlan_del
net: dsa: mv88e6xxx: call vtu_getnext directly in vlan_add

drivers/net/dsa/mv88e6xxx/chip.c | 182 +++++++++++++++++--------------
1 file changed, 98 insertions(+), 84 deletions(-)

--
2.22.0