Re: [PATCH] Add default binder devices through binderfs when configured

From: Christian Brauner
Date: Fri Aug 02 2019 - 11:06:27 EST


On Fri, Aug 02, 2019 at 08:18:38AM +0200, Greg Kroah-Hartman wrote:
> On Thu, Aug 01, 2019 at 03:35:56PM -0700, Hridya Valsaraju wrote:
> > If CONFIG_ANDROID_BINDERFS is set, the default binder devices
> > specified by CONFIG_ANDROID_BINDER_DEVICES are created in each
> > binderfs instance instead of global devices being created by
> > the binder driver.
> >
> > Co-developed-by: Christian Brauner <christian.brauner@xxxxxxxxxx>
> > Signed-off-by: Christian Brauner <christian.brauner@xxxxxxxxxx>
> > Signed-off-by: Hridya Valsaraju <hridya@xxxxxxxxxx>
> > ---
> > drivers/android/binder.c | 3 ++-
> > drivers/android/binderfs.c | 46 ++++++++++++++++++++++++++++++++++----
> > 2 files changed, 44 insertions(+), 5 deletions(-)
> >
> > diff --git a/drivers/android/binder.c b/drivers/android/binder.c
> > index 466b6a7f8ab7..65a99ac26711 100644
> > --- a/drivers/android/binder.c
> > +++ b/drivers/android/binder.c
> > @@ -6279,7 +6279,8 @@ static int __init binder_init(void)
> > &transaction_log_fops);
> > }
> >
> > - if (strcmp(binder_devices_param, "") != 0) {
> > + if (!IS_ENABLED(CONFIG_ANDROID_BINDERFS) &&
> > + strcmp(binder_devices_param, "") != 0) {
> > /*
> > * Copy the module_parameter string, because we don't want to
> > * tokenize it in-place.
> > diff --git a/drivers/android/binderfs.c b/drivers/android/binderfs.c
> > index e773f45d19d9..9f5ed50ffd70 100644
> > --- a/drivers/android/binderfs.c
> > +++ b/drivers/android/binderfs.c
> > @@ -48,6 +48,10 @@ static dev_t binderfs_dev;
> > static DEFINE_MUTEX(binderfs_minors_mutex);
> > static DEFINE_IDA(binderfs_minors);
> >
> > +static char *binder_devices_param = CONFIG_ANDROID_BINDER_DEVICES;
> > +module_param_named(devices, binder_devices_param, charp, 0444);
> > +MODULE_PARM_DESC(devices, "Binder devices to be created by default");
> > +
>
> Why are you creating a module parameter? That was not in your changelog
> :(

Yeah, you don't need an additional module parameter. You can just move

static char *binder_devices_param = CONFIG_ANDROID_BINDER_DEVICES;
module_param_named(devices, binder_devices_param, charp, 0444);

from binder.c to binder_internal.h and expose it to binder.c and
binderfs.c this way. This will work just fine since binderfs.c doesn't
modify the parameter and binder.c makes a copy of it before doing so.

>
>
>
> > /**
> > * binderfs_mount_opts - mount options for binderfs
> > * @max: maximum number of allocatable binderfs binder devices
> > @@ -135,7 +139,6 @@ static int binderfs_binder_device_create(struct inode *ref_inode,
> > #else
> > bool use_reserve = true;
> > #endif
> > -
> > /* Reserve new minor number for the new device. */
> > mutex_lock(&binderfs_minors_mutex);
> > if (++info->device_count <= info->mount_opts.max)
> > @@ -186,8 +189,7 @@ static int binderfs_binder_device_create(struct inode *ref_inode,
> > req->major = MAJOR(binderfs_dev);
> > req->minor = minor;
> >
> > - ret = copy_to_user(userp, req, sizeof(*req));
> > - if (ret) {
> > + if (userp && copy_to_user(userp, req, sizeof(*req))) {
> > ret = -EFAULT;
> > goto err;
> > }
> > @@ -467,6 +469,9 @@ static int binderfs_fill_super(struct super_block *sb, void *data, int silent)
> > int ret;
> > struct binderfs_info *info;
> > struct inode *inode = NULL;
> > + struct binderfs_device device_info = { 0 };
> > + const char *name;
> > + size_t len;
> >
> > sb->s_blocksize = PAGE_SIZE;
> > sb->s_blocksize_bits = PAGE_SHIFT;
> > @@ -521,7 +526,28 @@ static int binderfs_fill_super(struct super_block *sb, void *data, int silent)
> > if (!sb->s_root)
> > return -ENOMEM;
> >
> > - return binderfs_binder_ctl_create(sb);
> > + ret = binderfs_binder_ctl_create(sb);
> > + if (ret)
> > + return ret;
> > +
> > + name = binder_devices_param;
> > + for (len = strcspn(name, ","); len > 0; len = strcspn(name, ",")) {
> > + /*
> > + * init_binderfs() has already checked that the length of
> > + * device_name_entry->name is not greater than device_info.name.
> > + */
> > + strscpy(device_info.name, name, len + 1);
> > + ret = binderfs_binder_device_create(inode, NULL, &device_info);
> > + if (ret)
> > + return ret;
> > + name += len;
> > + if (*name == ',')
> > + name++;
> > +
> > + }
> > +
> > + return 0;
> > +
> > }
> >
> > static struct dentry *binderfs_mount(struct file_system_type *fs_type,
> > @@ -553,6 +579,18 @@ static struct file_system_type binder_fs_type = {
> > int __init init_binderfs(void)
> > {
> > int ret;
> > + const char *name;
> > + size_t len;
> > +
> > + /* Verify that the default binderfs device names are valid. */
> > + name = binder_devices_param;
> > + for (len = strcspn(name, ","); len > 0; len = strcspn(name, ",")) {
> > + if (len > BINDERFS_MAX_NAME)
> > + return -E2BIG;
> > + name += len;
> > + if (*name == ',')
> > + name++;
> > + }
>
> This verification should be a separate patch, right?
>
> But the real issue here is I have no idea _why_ you are wanting this
> patch. The changelog text says _what_ you are doing only, which isn't
> ok.
>
> Please provide more information as to why this is needed, what problem
> it is solving, and break this up into a patch series and resend.
>
> thanks,
>
> greg k-h