Re: [PATCH 1/1] block: Use bits.h macros to improve readability
From: Jens Axboe
Date: Sun Aug 04 2019 - 17:10:16 EST
On 8/4/19 1:17 PM, Joe Perches wrote:
> On Fri, 2019-08-02 at 21:18 -0700, Jens Axboe wrote:
>> On 8/1/19 6:00 PM, Leonardo Bras wrote:
>>> Applies some bits.h macros in order to improve readability of
>> I know precisely what that does, whereas I have to think about the other
>> one, maybe even look it up to be sure. For instance, without looking
>> now, I have no idea what the second argument is. Looking at the git log,
>> I see numerous instances of:
> While I'm not at all a proponent of GENMASK/GENMASK_ULL,
> and so not a proponent of this patch, latent defects are
> possible in both cases.
> You'd likely have to look at SOME_SHIFT to see if it's 0
> to verify the actual mask is what's really desired.
> $ git grep -P '_SHIFT\s+\(?\s*0\s*\)?\b' | wc -l
Usually SOME_SHIFT is either a numeric value, and you already know,
or it's part of a series of enums/defines (like in the case that's
being done here) where you already have prior knowledge about the
values. For those cases, GENMASK/GENMASK_ULL adds nothing imho, it
only makes it less readable and more error prone.