Re: [PATCH v2 03/14] arm64, hibernate: add trans_table public functions
From: Pavel Tatashin
Date: Tue Aug 20 2019 - 07:42:10 EST
> > > While the architecture uses the term 'translation table', in the kernel
> > > we generally use 'pgdir' or 'pgd' to refer to the tables, so please keep
> > > to that naming scheme.
> > The idea is to have a unique name space for new subsystem of page
> > tables that are used between kernels:
> > between stage 1 and stage 2 kexec kernel, and similarly between
> > kernels during hibernate boot process.
> > I picked: "trans_table" that stands for transitional page table:
> > meaning they are used only during transition between worlds.
> > All public functions in this subsystem will have trans_table_* prefix,
> > and page directory will be named: "trans_table". If this is confusing,
> > I can either use a different prefix, or describe what "trans_table"
> > stand for in trans_table.h/.c
> I think that "trans_table" is unfortunately confusing, as it clashes
> with the architecture terminology, and differs from what we have
> I think that "trans_pgd" would be better, as that better aligns with
> what we have elsewhere, and avoids the ambiguity.
Sounds good. I will rename trans_table* with trans_pgd*, and will also
add a note to the comments explaining what it stands for.