Re: erofs: Question on unused fields in on-disk structs
From: Richard Weinberger
Date: Thu Aug 22 2019 - 10:30:02 EST
On Thu, Aug 22, 2019 at 4:21 PM Theodore Y. Ts'o <tytso@xxxxxxx> wrote:
> It might make life easier for other kernel developers if "features"
> was named "compat_features" and "requirements" were named
> "incompat_features", just because of the long-standing use of that in
> ext2, ext3, ext4, ocfs2, etc. But that naming scheme really is a
> legacy of ext2 and its descendents, and there's no real reason why it
> has to be that way on other file systems.
Yes, the naming confused me a little. :-)