Re: [PATCH -next] ASoC: sun4i-i2s: Use PTR_ERR_OR_ZERO in sun4i_i2s_init_regmap_fields()

From: Yuehaibing
Date: Thu Aug 22 2019 - 10:35:26 EST


On 2019/8/22 22:18, Maxime Ripard wrote:
> Hi,
>
> On Thu, Aug 22, 2019 at 06:52:52AM +0000, YueHaibing wrote:
>> Use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) + PTR_ERR
>>
>> Signed-off-by: YueHaibing <yuehaibing@xxxxxxxxxx>
>> ---
>> sound/soc/sunxi/sun4i-i2s.c | 5 +----
>> 1 file changed, 1 insertion(+), 4 deletions(-)
>>
>> diff --git a/sound/soc/sunxi/sun4i-i2s.c b/sound/soc/sunxi/sun4i-i2s.c
>> index 9e691baee1e8..2071c54265f3 100644
>> --- a/sound/soc/sunxi/sun4i-i2s.c
>> +++ b/sound/soc/sunxi/sun4i-i2s.c
>> @@ -1095,10 +1095,7 @@ static int sun4i_i2s_init_regmap_fields(struct device *dev,
>> i2s->field_fmt_sr =
>> devm_regmap_field_alloc(dev, i2s->regmap,
>> i2s->variant->field_fmt_sr);
>> - if (IS_ERR(i2s->field_fmt_sr))
>> - return PTR_ERR(i2s->field_fmt_sr);
>> -
>> - return 0;
>> + return PTR_ERR_OR_ZERO(i2s->field_fmt_sr);
>
> I'm not really convinced that this more readable or more maintainable
> though. Is there a reason for this other than we can do it?

No special reason, just suggested by scripts/coccinelle/api/ptr_ret.cocci

>
> Maxie
>
> --
> Maxime Ripard, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
>