Re: [PATCH 01/15] sched: introduce task_se_h_load helper

From: Dietmar Eggemann
Date: Fri Aug 23 2019 - 14:13:55 EST




On 22/08/2019 04:17, Rik van Riel wrote:
> Sometimes the hierarchical load of a sched_entity needs to be calculated.
> Rename task_h_load to task_se_h_load, and directly pass a sched_entity to
> that function.
>
> Move the function declaration up above where it will be used later.
>
> No functional changes.
>
> Signed-off-by: Rik van Riel <riel@xxxxxxxxxxx>
> Reviewed-by: Josef Bacik <josef@xxxxxxxxxxxxxx>
> ---

[...]

> @@ -1668,7 +1668,7 @@ static void task_numa_compare(struct task_numa_env *env,
> /*
> * In the overloaded case, try and keep the load balanced.
> */
> - load = task_h_load(env->p) - task_h_load(cur);
> + load = task_se_h_load(env->p->se) - task_se_h_load(cur->se);

Shouldn't this be:

load = task_se_h_load(&env->p->se) - task_se_h_load(&cur->se);

> if (!load)
> goto assign;
>
> @@ -1706,7 +1706,7 @@ static void task_numa_find_cpu(struct task_numa_env *env,
> bool maymove = false;
> int cpu;
>
> - load = task_h_load(env->p);
> + load = task_se_h_load(env->p->se);

load = task_se_h_load(&env->p->se);

Only visible with CONFIG_NUMA_BALANCING though.

[...]