Re: [PATCH v2 4/7] mtd: spi-nor: Split spi_nor_init_params()

From: Boris Brezillon
Date: Sun Aug 25 2019 - 08:51:48 EST


On Sun, 25 Aug 2019 12:23:45 +0000
<Tudor.Ambarus@xxxxxxxxxxxxx> wrote:

> On 08/25/2019 03:03 PM, Boris Brezillon wrote:
> > External E-Mail
> >
> >
> > On Sat, 24 Aug 2019 12:00:43 +0000
> > <Tudor.Ambarus@xxxxxxxxxxxxx> wrote:
> >
> >> From: Tudor Ambarus <tudor.ambarus@xxxxxxxxxxxxx>
> >>
> >> Add functions to delimit what the chunks of code do:
> >>
> >> static void spi_nor_init_params()
> >> {
> >> spi_nor_legacy_init_params()
> >> spi_nor_manufacturer_init_params()
> >> spi_nor_sfdp_init_params()
> >> }
> >>
> >> Add descriptions to all methods.
> >>
> >> spi_nor_init_params() becomes of type void, as all its children
> >> return void.
> >>
> >> Signed-off-by: Tudor Ambarus <tudor.ambarus@xxxxxxxxxxxxx>
> >> ---
> >> drivers/mtd/spi-nor/spi-nor.c | 83 ++++++++++++++++++++++++++++++++-----------
> >> 1 file changed, 63 insertions(+), 20 deletions(-)
> >>
> >> diff --git a/drivers/mtd/spi-nor/spi-nor.c b/drivers/mtd/spi-nor/spi-nor.c
> >> index c9514dfd7d6d..93424f914159 100644
> >> --- a/drivers/mtd/spi-nor/spi-nor.c
> >> +++ b/drivers/mtd/spi-nor/spi-nor.c
> >> @@ -4186,7 +4186,34 @@ static void spi_nor_manufacturer_init_params(struct spi_nor *nor)
> >> nor->info->fixups->default_init(nor);
> >> }
> >>
> >> -static int spi_nor_init_params(struct spi_nor *nor)
> >> +/**
> >> + * spi_nor_sfdp_init_params() - Initialize the flash's parameters and settings
> >> + * based on JESD216 SFDP standard.
> >> + * @nor: pointer to a 'struct spi-nor'.
> >> + *
> >> + * The method has a roll-back mechanism: in case the SFDP parsing fails, the
> >> + * legacy flash parameters and settings will be restored.
> >> + */
> >> +static void spi_nor_sfdp_init_params(struct spi_nor *nor)
> >> +{
> >> + struct spi_nor_flash_parameter sfdp_params;
> >> +
> >> + memcpy(&sfdp_params, &nor->params, sizeof(sfdp_params));
> >> +
> >> + if (spi_nor_parse_sfdp(nor, &sfdp_params)) {
> >> + nor->addr_width = 0;
> >> + nor->flags &= ~SNOR_F_4B_OPCODES;
> >> + } else {
> >> + memcpy(&nor->params, &sfdp_params, sizeof(nor->params));
> >> + }
> >> +}
> >> +
> >> +/**
> >> + * spi_nor_legacy_init_params() - Initialize the flash's parameters and settings
> >> + * based on nor->info data.
> >> + * @nor: pointer to a 'struct spi-nor'.
> >> + */
> >> +static void spi_nor_legacy_init_params(struct spi_nor *nor)
> >
> > Nitpick: hm, I'm not a big fan of the 'legacy' term here as I'm not sure
> > it reflects the reality. I guess this function will stay around, and
> > even new NORs are not guaranteed to provide SFDP tables. How about
> > spi_nor_set_default_params() or spi_nor_info_init_params()?
>
> I can rename it to spi_nor_info_init_params() to be in sync with
> spi_nor_manufacturer_init_params() and
> spi_nor_sfdp_init_params()
>
> or I can rename all to:
> spi_nor_set_params()
> spi_nor_set_default_params()
> spi_nor_set_manufacturer_params()
> spi_nor_set_sfdp_params()
>
> Both are ok, but the second option seems better. What would you choose?

Both sound good, pick the one you prefer.