[RESEND PATCH v3 00/20] mtd: spi-nor: move manuf out of the core

From: Tudor.Ambarus
Date: Mon Aug 26 2019 - 08:08:37 EST


From: Tudor Ambarus <tudor.ambarus@xxxxxxxxxxxxx>

v3:
- Drop patches:
"mtd: spi-nor: Move clear_sr_bp() to 'struct spi_nor_flash_parameter'"
"mtd: spi-nor: Rework the disabling of block write protection"
and replace them with the RFC patch:
"mtd: spi-nor: Rework the disabling of block write protection"
- rename spi_nor_legacy_init_params() to spi_nor_info_init_params()
- rebase patches and send them all in a single patch set.

v2:
- addressed all the comments
- all flash parameters and settings are now set in 'struct
spi_nor_flash_parameter', for a clearer separation between the SPI NOR
layer and the flash params.

In order to test this, you'll have to merge v5.3-rc5 in spi-nor/next.
This patch set depends on
'commit 834de5c1aa76 ("mtd: spi-nor: Fix the disabling of write protection at init")

The scope of the "mtd: spi-nor: move manuf out of the core" batches,
is to move all manufacturer specific code out of the spi-nor core.

In the quest of removing the manufacturer specific code from the spi-nor
core, we want to impose a timeline/priority on how the flash parameters
are updated. As of now. the flash parameters initialization logic is as
following:

a/ default flash parameters init in spi_nor_init_params()
b/ manufacturer specific flash parameters updates, split across entire
spi-nor core code
c/ flash parameters updates based on SFDP tables
d/ post BFPT flash parameter updates

With the "mtd: spi-nor: move manuf out of the core" batches, we want to
impose the following sequence of calls:

1/ spi-nor core legacy flash parameters init:
spi_nor_default_init_params()

2/ MFR-based manufacturer flash parameters init:
nor->manufacturer->fixups->default_init()

3/ specific flash_info tweeks done when decisions can not be done just
on MFR:
nor->info->fixups->default_init()

4/ SFDP tables flash parameters init - SFDP knows better:
spi_nor_sfdp_init_params()

5/ post SFDP tables flash parameters updates - in case manufacturers
get the serial flash tables wrong or incomplete.
nor->info->fixups->post_sfdp()
The later can be extended to nor->manufacturer->fixups->post_sfdp()
if needed.

Setting of flash parameters will no longer be spread interleaved across
the spi-nor core, there will be a clear separation on who and when will
update the flash parameters.

Tested on sst26vf064b with atmel-quadspi SPIMEM driver.

Boris Brezillon (7):
mtd: spi-nor: Add a default_init() fixup hook for gd25q256
mtd: spi-nor: Create a ->set_4byte() method
mtd: spi-nor: Rework the SPI NOR lock/unlock logic
mtd: spi-nor: Add post_sfdp() hook to tweak flash config
mtd: spi-nor: Add spansion_post_sfdp_fixups()
mtd: spi-nor: Add a ->convert_addr() method
mtd: spi-nor: Add the SPI_NOR_XSR_RDY flag

Tudor Ambarus (13):
mtd: spi-nor: Regroup flash parameter and settings
mtd: spi-nor: Use nor->params
mtd: spi-nor: Drop quad_enable() from 'struct spi-nor'
mtd: spi-nor: Move erase_map to 'struct spi_nor_flash_parameter'
mtd: spi-nor: Add default_init() hook to tweak flash parameters
mtd: spi_nor: Move manufacturer quad_enable() in ->default_init()
mtd: spi-nor: Split spi_nor_init_params()
mtd: spi_nor: Add a ->setup() method
mtd: spi-nor: Add s3an_post_sfdp_fixups()
mtd: spi-nor: Bring flash params init together
mtd: spi_nor: Introduce spi_nor_set_addr_width()
mtd: spi-nor: Introduce spi_nor_get_flash_info()
mtd: spi-nor: Rework the disabling of block write protection

drivers/mtd/spi-nor/spi-nor.c | 1304 +++++++++++++++++++++++------------------
include/linux/mtd/spi-nor.h | 298 +++++++---
2 files changed, 927 insertions(+), 675 deletions(-)

--
2.9.5