Re: [patch V3 28/38] posix-cpu-timers: Restructure expiry array
From: Frederic Weisbecker
Date: Mon Aug 26 2019 - 15:45:44 EST
On Mon, Aug 26, 2019 at 08:22:24PM +0200, Thomas Gleixner wrote:
> Now that the abused struct task_cputime is gone, it's more natural to
> bundle the expiry cache and the list head of each clock into a struct and
> have an array of those structs.
> Follow the hrtimer naming convention of 'bases' and rename the expiry cache
> to 'nextevt' and adapt all usage sites.
> Generates also better code .text size shrinks by 80 bytes.
> Suggested-by: Ingo Molnar <mingo@xxxxxxxxxx>
> Signed-off-by: Thomas Gleixner <tglx@xxxxxxxxxxxxx>
> V2: New patch
> V3: Address review feedback from Frederic
Reviewed-by: Frederic Weisbecker <frederic@xxxxxxxxxx>