Re: [PATCH] doc:lock: remove reference to clever use of read-write lock
From: Federico Vaga
Date: Mon Sep 02 2019 - 17:07:10 EST
On Monday, September 2, 2019 10:21:33 PM CEST Jonathan Corbet wrote:
> On Mon, 02 Sep 2019 21:19:24 +0200
> Federico Vaga <federico.vaga@xxxxxxxxxx> wrote:
> > > > I am not used to the mathematical English jargon. It make sense, but
> > > > then
> > > > I
> > > > would replace it with "If and only if": for clarity.
> > >
> > > While it's used in a number of places and it's pretty common wording
> > > overall in the literature, I agree that we should probably change this
> > > in
> > > locking API user facing documentation.
> > I would say not only in locking/. The argument is valid for the entire
> > Documentation/. I wait for Jon's opinion before proceeding.
> I don't really have a problem with "iff"; it doesn't seem like *that*
> obscure a term to me. But if you want spell it out, I guess I don't have
> a problem with that. We can change it - iff you send a patch to do it :)
I do not mind too, once I got the meaning of IFF to *me* is clear and
translatable to SSE (i will not).
My opinion is that abbreviations should not be used in general. But it is a
weak opinion. I can do, and send, a patch