Re: [PATCH v3 2/2] kbuild: rename KBUILD_ENABLE_EXTRA_GCC_CHECKS to KBUILD_EXTRA_WARN
From: Sedat Dilek
Date: Wed Sep 04 2019 - 04:08:09 EST
On Wed, Sep 4, 2019 at 8:58 AM Sedat Dilek <sedat.dilek@xxxxxxxxx> wrote:
> On Tue, Sep 3, 2019 at 11:50 PM Nick Desaulniers
> <ndesaulniers@xxxxxxxxxx> wrote:
> > On Sat, Aug 31, 2019 at 9:26 AM Masahiro Yamada
> > <yamada.masahiro@xxxxxxxxxxxxx> wrote:
> > >
> > > KBUILD_ENABLE_EXTRA_GCC_CHECKS started as a switch to add extra warning
> > > options for GCC, but now it is a historical misnomer since we use it
> > > also for Clang, DTC, and even kernel-doc.
> > Thanks for the patch!
> > Reviewed-by: Nick Desaulniers <ndesaulniers@xxxxxxxxxx>
> Thanks for the patch.
> I like the backward compatibility and am OK with pointing to 'make
> --help' for the documentation part (KISS - Keep It Simple and
> Reviewed-by: Sedat Dilek <sedat.dilek@xxxxxxxxx>
If you will do a next version...
- @echo ' make W=n [targets] Enable extra gcc checks, n=1,2,3 where'
+ @echo ' make W=n [targets] Enable extra checks, n=1,2,3 where'
...clarify on extra checks for compiler...
+ @echo ' make W=n [targets] Enable extra *compiler* checks, n=1,2,3 where'
Thanks in advance.
- Sedat -