Re: [PATCH v2 1/2] gpiolib: introduce devm_fwnode_gpiod_get_index()

From: Mika Westerberg
Date: Fri Sep 13 2019 - 05:40:28 EST

On Thu, Sep 12, 2019 at 08:22:38PM -0700, Dmitry Torokhov wrote:
> devm_fwnode_get_index_gpiod_from_child() is too long, besides the fwnode
> in question does not have to be a child of device node. Let's rename it
> to devm_fwnode_gpiod_get_index() and keep the old name for compatibility
> for now.

Shouldn't we convert all the users and drop that monstrosity
devm_fwnode_get_index_gpiod_from_child() completely?