Re: [PATCH 02/11] gpiolib: introduce devm_fwnode_gpiod_get_index()
From: Dmitry Torokhov
Date: Fri Sep 13 2019 - 14:14:08 EST
On Thu, Sep 12, 2019 at 10:48:13AM +0100, Linus Walleij wrote:
> On Wed, Sep 11, 2019 at 8:52 AM Dmitry Torokhov
> <dmitry.torokhov@xxxxxxxxx> wrote:
> > devm_fwnode_get_index_gpiod_from_child() is too long, besides the fwnode
> > in question does not have to be a child of device node. Let's rename it
> > to devm_fwnode_gpiod_get_index() and keep the old name for compatibility
> > for now.
> > Also let's add a devm_fwnode_gpiod_get() wrapper as majority of the
> > callers need a single GPIO.
> > Signed-off-by: Dmitry Torokhov <dmitry.torokhov@xxxxxxxxx>
> The patch is good because this is in line with Rusty Russells API
> 7. The obvious use is (probably) the correct one.
> 6. The name tells you how to use it.
> It doesn't apply to my "devel" branch as of now:
> If you rebase this and the next patch and send them separately I
> am willing to apply them already for v5.4 to easy your refactoring
> work during the v5.5 cycle here, provided we try to fix up the old users
> ASAP and delete the compatibility fallbacks in the near future.