Re: [PATCH 3/3] tracing/hwlat: Fix a few trivial nits
From: Steven Rostedt
Date: Thu Oct 10 2019 - 17:44:31 EST
On Thu, 10 Oct 2019 14:34:55 -0700
Joe Perches <joe@xxxxxxxxxxx> wrote:
> On Thu, 2019-10-10 at 11:51 -0700, Srivatsa S. Bhat wrote:
> > Update the source file name in the comments, and fix a grammatical
> > error.
> > diff --git a/kernel/trace/trace_hwlat.c b/kernel/trace/trace_hwlat.c
> > @@ -1,6 +1,6 @@
> > // SPDX-License-Identifier: GPL-2.0
> > /*
> > - * trace_hwlatdetect.c - A simple Hardware Latency detector.
> > + * trace_hwlat.c - A simple Hardware Latency detector.
> Generally it's not useful to have the filename in a comment
> so I think maybe delete the "trace_hwlatdetect.c - ".
Not a big deal to keep it. The original proposed name for the tracer was
hwlatdetect, but people said it was too long and hwlat was good enough.
Thus we changed the name to that, but didn't change the comment here.
We could remove it, but I think it's fine to keep it.
> $ git ls-files -- '*.[ch]' | \
> while read file ; do git grep $file -- $file; done | wc -l
> About 5% (2500 of the 50000 or so) *.[ch] files in the kernel
> source tree contain their filename in a comment, so it's
> certainly not that unusual.