Re: [PATCH v2 01/29] powerpc: Rename "notes" PT_NOTE to "note"

From: Segher Boessenkool
Date: Fri Oct 11 2019 - 12:26:52 EST

On Fri, Oct 11, 2019 at 09:11:43AM -0700, Kees Cook wrote:
> On Fri, Oct 11, 2019 at 03:25:19AM -0500, Segher Boessenkool wrote:
> > On Thu, Oct 10, 2019 at 05:05:41PM -0700, Kees Cook wrote:
> > > The Program Header identifiers are internal to the linker scripts. In
> > > preparation for moving the NOTES segment declaration into RO_DATA,
> > > standardize the identifier for the PT_NOTE entry to "note" as used by
> > > all other architectures that emit PT_NOTE.
> >
> > All other archs are wrong, and "notes" is a much better name. This
> > segment does not contain a single "note", but multiple "notes".
> True, but the naming appears to be based off the Program Header name of
> "PT_NOTE".

Ah, so that's why the kernel segment (which isn't text btw, it's rwx) is
called "load" :-P

(Not convinced. Some arch just got it wrong, and many others blindly
copied it? That sounds a lot more likely imo.)

> Regardless, it is an entirely internal-to-the-linker-script
> identifier, so I am just consolidating on a common name with the least
> number of collateral changes.

Yes, that's what I'm complaining about.

Names *matter*, internal names doubly so. So why replace a good name with
a worse name? Because it is slightly less work for you?


p.s. Thanks for doing this, removing the powerpc workaround etc. :-)