Re: [PATCH 1/8] ftrace: add ftrace_init_nop()

From: Steven Rostedt
Date: Mon Oct 21 2019 - 14:08:01 EST


On Mon, 21 Oct 2019 17:34:19 +0100
Mark Rutland <mark.rutland@xxxxxxx> wrote:

> Architectures may need to perform special initialization of ftrace
> callsites, and today they do so by special-casing ftrace_make_nop() when
> the expected branch address is MCOUNT_ADDR. In some cases (e.g. for
> patchable-function-entry), we don't have an mcount-like symbol and don't
> want a synthetic MCOUNT_ADDR, but we may need to perform some
> initialization of callsites.
>
> To make it possible to separate initialization from runtime
> modification, and to handle cases without an mcount-like symbol, this
> patch adds an optional ftrace_init_nop() function that architectures can
> implement, which does not pass a branch address.
>
> Where an architecture does not provide ftrace_init_nop(), we will fall
> back to the existing behaviour of calling ftrace_make_nop() with
> MCOUNT_ADDR.
>
> At the same time, ftrace_code_disable() is renamed to
> ftrace_code_init_disabled() to make it clearer that it is intended to
> intialize a callsite into a disabled state, and is not for disabling a
> callsite that has been runtime enabled.

To make the name even better, let's just rename it to:

ftrace_nop_initialization()

I think that may be the best description for it.

>
> Signed-off-by: Mark Rutland <mark.rutland@xxxxxxx>
> Cc: Ingo Molnar <mingo@xxxxxxxxxx>
> Cc: Steven Rostedt <rostedt@xxxxxxxxxxx>
> Cc: Torsten Duwe <duwe@xxxxxxx>
> ---
> kernel/trace/ftrace.c | 13 ++++++++++---
> 1 file changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/kernel/trace/ftrace.c b/kernel/trace/ftrace.c
> index f296d89be757..afd7e210e595 100644
> --- a/kernel/trace/ftrace.c
> +++ b/kernel/trace/ftrace.c
> @@ -2493,15 +2493,22 @@ struct dyn_ftrace *ftrace_rec_iter_record(struct ftrace_rec_iter *iter)
> return &iter->pg->records[iter->index];
> }
>
> +#ifndef ftrace_init_nop
> +static int ftrace_init_nop(struct module *mod, struct dyn_ftrace *rec)
> +{
> + return ftrace_make_nop(mod, rec, MCOUNT_ADDR);
> +}
> +#endif

Can you place the above in the ftrace.h header. That's where that would
belong.

#ifndef ftrace_init_nop
struct module;
static inline int ftrace_init_nop(struct module *mod, struct dyn_ftrace *rec)
{
return ftrace_make_nop(mod, rec, MCOUNT_ADDR);
}
#endif

-- Steve

> +
> static int
> -ftrace_code_disable(struct module *mod, struct dyn_ftrace *rec)
> +ftrace_code_init_disabled(struct module *mod, struct dyn_ftrace *rec)
> {
> int ret;
>
> if (unlikely(ftrace_disabled))
> return 0;
>
> - ret = ftrace_make_nop(mod, rec, MCOUNT_ADDR);
> + ret = ftrace_init_nop(mod, rec);
> if (ret) {
> ftrace_bug_type = FTRACE_BUG_INIT;
> ftrace_bug(ret, rec);
> @@ -2943,7 +2950,7 @@ static int ftrace_update_code(struct module *mod, struct ftrace_page *new_pgs)
> * to the NOP instructions.
> */
> if (!__is_defined(CC_USING_NOP_MCOUNT) &&
> - !ftrace_code_disable(mod, p))
> + !ftrace_code_init_disabled(mod, p))
> break;
>
> update_cnt++;