[PATCH v2 00/11] gpio: pca953x: Convert to bitmap (extended) API

From: Andy Shevchenko
Date: Tue Oct 22 2019 - 13:29:31 EST


While converting gpio-pca953x driver to bitmap API, I noticed that we have
no function to replace bits.

So, that's how patch 7 appears.

First 6 patches are preparatory of the test suite (including some warning
fixes, etc).

Patches 8-9 are preparatory for the GPIO driver to be easier converted
to bitmap API, conversion to which happens in patch 10.

Patch 11 simple indentation fixes.

Since the series depends to the commit e51819d749db ("bitops: introduce the
for_each_set_clump8 macro") in Andrew's set and taking into consideration
a lot of bitmap related patches here, it would make sense to route these thru
Andrew as well.

In v2:
- address wrong logic in pca953x_gpio_set_multiple() (William)
- 10 more patches as described above

Andy Shevchenko (11):
lib/test_bitmap: Force argument of bitmap_parselist_user() to proper
address space
lib/test_bitmap: Undefine macros after use
lib/test_bitmap: Name EXP_BYTES properly
lib/test_bitmap: Rename exp to exp1 to avoid ambiguous name
lib/test_bitmap: Move exp1 and exp2 upper for others to use
lib/test_bitmap: Fix comment about this file
bitmap: Introduce bitmap_replace() helper
gpio: pca953x: Remove redundant variable and check in IRQ handler
gpio: pca953x: Use input from regs structure in pca953x_irq_pending()
gpio: pca953x: Convert to use bitmap API
gpio: pca953x: Tight up indentation

drivers/gpio/gpio-pca953x.c | 196 ++++++++++++++++--------------------
include/linux/bitmap.h | 16 +++
lib/bitmap.c | 12 +++
lib/test_bitmap.c | 137 ++++++++++++++++---------
4 files changed, 203 insertions(+), 158 deletions(-)

--
2.23.0