Re: [PATCH v2 2/4] skd: Replace magic numbers with PCI constants

From: Damien Le Moal
Date: Sun Nov 17 2019 - 20:45:56 EST


On 2019/11/18 9:21, Frederick Lawler wrote:
> Readability was improved by replacing pci_read_config_word() with
> pcie_capability_read_word(). Take that a step further by replacing magic
> numbers with PCI reg constants.
>
> No functional change intended.
>
> Signed-off-by: Frederick Lawler <fred@xxxxxxxxxxxx>
> ---
> v2
> - Added this patch
> ---
> drivers/block/skd_main.c | 8 +++++---
> 1 file changed, 5 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/block/skd_main.c b/drivers/block/skd_main.c
> index f25f6ef6b4c7..7f8243573ad9 100644
> --- a/drivers/block/skd_main.c
> +++ b/drivers/block/skd_main.c
> @@ -3141,9 +3141,11 @@ static char *skd_pci_info(struct skd_device *skdev, char *str)
> char lwstr[6];
> uint16_t pcie_lstat, lspeed, lwidth;
>
> - pcie_capability_read_word(skdev->pdev, 0x12, &pcie_lstat);
> - lspeed = pcie_lstat & (0xF);
> - lwidth = (pcie_lstat & 0x3F0) >> 4;
> + pcie_capability_read_word(skdev->pdev, PCI_EXP_LNKSTA,
> + &pcie_lstat);
> + lspeed = pcie_lstat & PCI_EXP_LNKSTA_CLS;
> + lwidth = (pcie_lstat & PCI_EXP_LNKSTA_NLW) >>
> + PCI_EXP_LNKSTA_NLW_SHIFT;
>
> if (lspeed == 1)
> strcat(str, "2.5GT/s ");
>

Looks OK to me. But since this is changing again one line that is added
by patch 1/4, why not make patch 1 and this patch changes a single patch ?

--
Damien Le Moal
Western Digital Research