Re: [PATCH v3 02/10] lib: introduce generic min max heap

From: Peter Zijlstra
Date: Mon Nov 18 2019 - 03:41:43 EST


On Sun, Nov 17, 2019 at 10:28:09AM -0800, Joe Perches wrote:
> On Wed, 2019-11-13 at 16:30 -0800, Ian Rogers wrote:
> > Based-on-work-by: Peter Zijlstra (Intel) <peterz@xxxxxxxxxxxxx>
>
> Perhaps some functions are a bit large for inline

It all hard relies on always inline to have the indirect function
pointers constant folded and inlined too.

See for example also: include/linux/rbtree_augmented.h

Yes, its a bit crud, but performance mandates it.

> and perhaps the function names are too generic?

Yeah, noted that already.