Re: [PATCH] hexagon: io: Define ioremap_uc to fix build error

From: Geert Uytterhoeven
Date: Tue Dec 10 2019 - 03:45:48 EST


Hi GÃnter,

On Tue, Dec 10, 2019 at 9:23 AM Guenter Roeck <linux@xxxxxxxxxxxx> wrote:
> On 12/10/19 12:09 AM, Geert Uytterhoeven wrote:
> > On Wed, Dec 4, 2019 at 2:34 PM Guenter Roeck <linux@xxxxxxxxxxxx> wrote:
> >> ioremap_uc is now mandatory.
> >>
> >> lib/devres.c:44:3: error: implicit declaration of function 'ioremap_uc'
> >>
> >> Fixes: e537654b7039 ("lib: devres: add a helper function for ioremap_uc")
> >> Cc: Tuowen Zhao <ztuowen@xxxxxxxxx>
> >> Cc: Mika Westerberg <mika.westerberg@xxxxxxxxxxxxxxx>
> >> Cc: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> >> Cc: Luis Chamberlain <mcgrof@xxxxxxxxxx>
> >> Cc: Lee Jones <lee.jones@xxxxxxxxxx>
> >> Signed-off-by: Guenter Roeck <linux@xxxxxxxxxxxx>
> >> ---
> >> arch/hexagon/include/asm/io.h | 2 +-
> >> 1 file changed, 1 insertion(+), 1 deletion(-)
> >>
> >> diff --git a/arch/hexagon/include/asm/io.h b/arch/hexagon/include/asm/io.h
> >> index 539e3efcf39c..39e5605c5d42 100644
> >> --- a/arch/hexagon/include/asm/io.h
> >> +++ b/arch/hexagon/include/asm/io.h
> >> @@ -173,7 +173,7 @@ static inline void writel(u32 data, volatile void __iomem *addr)
> >>
> >> void __iomem *ioremap(unsigned long phys_addr, unsigned long size);
> >> #define ioremap_nocache ioremap
> >> -
> >> +#define ioremap_uc ioremap
> >>
> >> #define __raw_writel writel
> >
> > Do we really need this? There is only one user of ioremap_uc(), which
> > Christoph is trying hard to get rid of, and the new devres helper that
> > triggers all of this :-(
> > https://lore.kernel.org/dri-devel/20191112105507.GA7122@xxxxxx/
>
> One may ask why we needed a devres helper in the first place if there
> is indeed just one user.

Because of the new second user, which jumped on the devres train...
a8ff78f7f773142e ("mfd: intel-lpss: Use devm_ioremap_uc for MMIO").

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds