Re: [PATCH V3 1/4] arm64: dts: sc7180: Add Venus video codec DT node

From: Stanimir Varbanov
Date: Tue Jan 07 2020 - 08:52:50 EST


Hi,

On 1/2/20 3:24 PM, Dikshita Agarwal wrote:
> This adds Venus video codec DT node for sc7180.
>
> Signed-off-by: Dikshita Agarwal <dikshita@xxxxxxxxxxxxxx>
> ---
> arch/arm64/boot/dts/qcom/sc7180.dtsi | 36 ++++++++++++++++++++++++++++++++++++
> 1 file changed, 36 insertions(+)
>
> diff --git a/arch/arm64/boot/dts/qcom/sc7180.dtsi b/arch/arm64/boot/dts/qcom/sc7180.dtsi
> index 3676bfd..fa849de 100644
> --- a/arch/arm64/boot/dts/qcom/sc7180.dtsi
> +++ b/arch/arm64/boot/dts/qcom/sc7180.dtsi
> @@ -10,6 +10,7 @@
> #include <dt-bindings/interrupt-controller/arm-gic.h>
> #include <dt-bindings/phy/phy-qcom-qusb2.h>
> #include <dt-bindings/soc/qcom,rpmh-rsc.h>
> +#include <dt-bindings/clock/qcom,videocc-sc7180.h>
>
> / {
> interrupt-parent = <&intc>;
> @@ -66,6 +67,11 @@
> compatible = "qcom,cmd-db";
> no-map;
> };
> +
> + venus_mem: memory@8f600000 {
> + reg = <0 0x8f600000 0 0x500000>;
> + no-map;
> + };
> };
>
> cpus {
> @@ -1043,6 +1049,36 @@
> };
> };
>
> + venus: video-codec@aa00000 {
> + compatible = "qcom,sc7180-venus";
> + reg = <0 0x0aa00000 0 0xff000>;
> + interrupts = <GIC_SPI 174 IRQ_TYPE_LEVEL_HIGH>;
> + power-domains = <&videocc VENUS_GDSC>,
> + <&videocc VCODEC0_GDSC>;
> + power-domain-names = "venus", "vcodec0";
> + clocks = <&videocc VIDEO_CC_VENUS_CTL_CORE_CLK>,
> + <&videocc VIDEO_CC_VENUS_AHB_CLK>,
> + <&videocc VIDEO_CC_VENUS_CTL_AXI_CLK>,
> + <&videocc VIDEO_CC_VCODEC0_CORE_CLK>,
> + <&videocc VIDEO_CC_VCODEC0_AXI_CLK>;
> + clock-names = "core", "iface", "bus",
> + "vcodec0_core", "vcodec0_bus";

Please, align this as you made it for clocks.

> + iommus = <&apps_smmu 0x0c00 0x60>;
> + memory-region = <&venus_mem>;
> +
> + interconnects = <&mmss_noc MASTER_VIDEO_P0 &mc_virt SLAVE_EBI1>,
> + <&gem_noc MASTER_APPSS_PROC &config_noc SLAVE_VENUS_CFG>;
> + interconnect-names = "video-mem", "cpu-cfg";
> +
> + video-core0 {

The subnode name isn't correct because we have only one core. Could you
rename it to video-decoder.

> + compatible = "venus-decoder";
> + };
> +
> + video-core1 {

rename to video-encoder

> + compatible = "venus-encoder";
> + };
> + };
> +
> pdc: interrupt-controller@b220000 {
> compatible = "qcom,sc7180-pdc", "qcom,pdc";
> reg = <0 0x0b220000 0 0x30000>;
>

--
regards,
Stan