[PATCH v2 1/3] powerpc/irq: don't use current_stack_pointer() in check_stack_overflow()

From: Christophe Leroy
Date: Fri Jan 24 2020 - 02:07:56 EST


current_stack_pointer() doesn't return the stack pointer, but the
caller's stack frame. See commit bfe9a2cfe91a ("powerpc: Reimplement
__get_SP() as a function not a define") and commit acf620ecf56c
("powerpc: Rename __get_SP() to current_stack_pointer()") for details.

The purpose of check_stack_overflow() is to verify that the stack has
not overflowed.

To really know whether the stack pointer is still within boundaries,
the check must be done directly on the value of r1.

Define a get_sp() macro to get the value of r1 directly. (Adapted from
arch/powerpc/boot/reg.h)

Signed-off-by: Christophe Leroy <christophe.leroy@xxxxxx>
---
v2: Define a get_sp() macro instead of using asm("r1") locally.
---
arch/powerpc/include/asm/reg.h | 3 +++
arch/powerpc/kernel/irq.c | 2 +-
2 files changed, 4 insertions(+), 1 deletion(-)

diff --git a/arch/powerpc/include/asm/reg.h b/arch/powerpc/include/asm/reg.h
index 1aa46dff0957..d585f2566338 100644
--- a/arch/powerpc/include/asm/reg.h
+++ b/arch/powerpc/include/asm/reg.h
@@ -1450,6 +1450,9 @@ static inline void mtsrin(u32 val, u32 idx)

extern unsigned long current_stack_pointer(void);

+register unsigned long __stack_pointer asm("r1");
+#define get_sp() (__stack_pointer)
+
extern unsigned long scom970_read(unsigned int address);
extern void scom970_write(unsigned int address, unsigned long value);

diff --git a/arch/powerpc/kernel/irq.c b/arch/powerpc/kernel/irq.c
index add67498c126..cd29c2eb2d8e 100644
--- a/arch/powerpc/kernel/irq.c
+++ b/arch/powerpc/kernel/irq.c
@@ -601,7 +601,7 @@ static inline void check_stack_overflow(void)
#ifdef CONFIG_DEBUG_STACKOVERFLOW
long sp;

- sp = current_stack_pointer() & (THREAD_SIZE-1);
+ sp = get_sp() & (THREAD_SIZE - 1);

/* check for stack overflow: is there less than 2KB free? */
if (unlikely(sp < 2048)) {
--
2.25.0