Re: [PATCH 3/3] mtd: spinand: Wait for the erase op to finish before writing a bad block marker

From: Schrempf Frieder
Date: Mon Feb 17 2020 - 06:29:56 EST


Hi Boris,

On 17.02.20 12:14, Boris Brezillon wrote:
> On Mon, 17 Feb 2020 11:39:19 +0100
> Miquel Raynal <miquel.raynal@xxxxxxxxxxx> wrote:
>
>> Hi Frieder,
>>
>> Schrempf Frieder <frieder.schrempf@xxxxxxxxxx> wrote on Tue, 11 Feb
>> 2020 16:35:53 +0000:
>>
>>> From: Frieder Schrempf <frieder.schrempf@xxxxxxxxxx>
>>>
>>> Currently when marking a block, we use spinand_erase_op() to erase
>>> the block before writing the marker to the OOB area without waiting
>>> for the operation to succeed. This can lead to the marking failing
>>> silently and no bad block marker being written to the flash.
>>>
>>> To fix this we reuse the spinand_erase() function, that already does
>>> everything we need to do before actually writing the marker.
>>>
>>
>> Thanks a lot for this series!
>>
>> Yet I don't really understand the point of waiting for the erasure if
>> it failed: we don't really care as programming (1 -> 0) cells is always
>> possible. Are you sure this lead to an error?
>
> Actually, I think I already pointed out that we should probably write
> the BBM without erasing the block. IIRC, this logic has been copied
> from rawnand where some controllers don't disable the ECC engine when
> doing raw accesses, leading to ECC errors if the block is not erased
> before BBMs are programmed. Assuming we don't let such drivers being
> merged in spinand, this erase operation can be dropped.

You're probably right, we could also just write the BBM without erasing
the block. I will try if this works in my setup and update the patch.

>
>>
>> Also, why just not calling spinand_erase() instead of
>> spinand_erase_op() from spinand_markbad()?
>>
>>> Fixes: 7529df465248 ("mtd: nand: Add core infrastructure to support SPI NANDs")
>>> Cc: stable@xxxxxxxxxxxxxxx
>>> Signed-off-by: Frieder Schrempf <frieder.schrempf@xxxxxxxxxx>
>>> ---
>>> drivers/mtd/nand/spi/core.c | 56 ++++++++++++++++++-------------------
>>> 1 file changed, 28 insertions(+), 28 deletions(-)
>>>
>>> diff --git a/drivers/mtd/nand/spi/core.c b/drivers/mtd/nand/spi/core.c
>>> index 925db6269861..8a69d13639e2 100644
>>> --- a/drivers/mtd/nand/spi/core.c
>>> +++ b/drivers/mtd/nand/spi/core.c
>>> @@ -600,6 +600,32 @@ static int spinand_mtd_block_isbad(struct mtd_info *mtd, loff_t offs)
>>> return ret;
>>> }
>>>
>>> +static int __spinand_erase(struct nand_device *nand, const struct nand_pos *pos,
>>> + bool hard_fail)
>
> I hate those __ prefix. Please find a more descriptive name
> (spinand_erase_block() or spinand_erase_and_wait()?)

Actually I was expecting this comment ;)
And I totally agree. I was just lazy to come up with a name.
If we follow the approach without erase, I can get rid of this anyway.

Thanks,
Frieder

>
>>> +{
>>> + struct spinand_device *spinand = nand_to_spinand(nand);
>>> + u8 status;
>>> + int ret;
>>> +
>>> + ret = spinand_select_target(spinand, pos->target);
>>> + if (ret)
>>> + return ret;
>>> +
>>> + ret = spinand_write_enable_op(spinand);
>>> + if (ret)
>>> + return ret;
>>> +
>>> + ret = spinand_erase_op(spinand, pos);
>>> + if (ret && hard_fail)
>>> + return ret;
>>> +
>>> + ret = spinand_wait(spinand, &status);
>>> + if (!ret && (status & STATUS_ERASE_FAILED))
>>> + ret = -EIO;
>>> +
>>> + return ret;
>>> +}
>>> +
>>> static int spinand_markbad(struct nand_device *nand, const struct nand_pos *pos)
>>> {
>>> struct spinand_device *spinand = nand_to_spinand(nand);
>>> @@ -614,16 +640,10 @@ static int spinand_markbad(struct nand_device *nand, const struct nand_pos *pos)
>>> int ret;
>>>
>>> /* Erase block before marking it bad. */
>>> - ret = spinand_select_target(spinand, pos->target);
>>> - if (ret)
>>> - return ret;
>>> -
>>> - ret = spinand_write_enable_op(spinand);
>>> + ret = __spinand_erase(nand, pos, false);
>>> if (ret)
>>> return ret;
>>>
>>> - spinand_erase_op(spinand, pos);
>>> -
>>> return spinand_write_page(spinand, &req);
>>> }
>>>
>>> @@ -644,27 +664,7 @@ static int spinand_mtd_block_markbad(struct mtd_info *mtd, loff_t offs)
>>>
>>> static int spinand_erase(struct nand_device *nand, const struct nand_pos *pos)
>>> {
>>> - struct spinand_device *spinand = nand_to_spinand(nand);
>>> - u8 status;
>>> - int ret;
>>> -
>>> - ret = spinand_select_target(spinand, pos->target);
>>> - if (ret)
>>> - return ret;
>>> -
>>> - ret = spinand_write_enable_op(spinand);
>>> - if (ret)
>>> - return ret;
>>> -
>>> - ret = spinand_erase_op(spinand, pos);
>>> - if (ret)
>>> - return ret;
>>> -
>>> - ret = spinand_wait(spinand, &status);
>>> - if (!ret && (status & STATUS_ERASE_FAILED))
>>> - ret = -EIO;
>>> -
>>> - return ret;
>>> + return __spinand_erase(nand, pos, true);
>>> }
>>>
>>> static int spinand_mtd_erase(struct mtd_info *mtd,
>>
>> Thanks,
>> MiquÃl
>