Re: [PATCH] KVM: x86: eliminate some unreachable code
Date: Mon Feb 17 2020 - 20:19:19 EST
Vitaly Kuznetsov <vkuznets@xxxxxxxxxx> writes:
>linmiaohe <linmiaohe@xxxxxxxxxx> writes:
>> @@ -4505,7 +4505,6 @@ static bool rmode_exception(struct kvm_vcpu *vcpu, int vec)
>> case GP_VECTOR:
>> case MF_VECTOR:
>> return true;
>> - break;
>> return false;
>Unrelated to your change but what I don't in rmode_exception() is the second "/* fall through */" instead of just 'return true;', it makes it harder to read.
Agree. I will do it in another patch as it's unrelated to this one. Many Thanks for your review and advice.