Re: [PATCH v6 04/19] mm: Rearrange readahead loop

From: John Hubbard
Date: Tue Feb 18 2020 - 17:33:36 EST


On 2/17/20 10:45 AM, Matthew Wilcox wrote:
> From: "Matthew Wilcox (Oracle)" <willy@xxxxxxxxxxxxx>
>
> Move the declaration of 'page' to inside the loop and move the 'kick
> off a fresh batch' code to the end of the function for easier use in
> subsequent patches.
>
> Signed-off-by: Matthew Wilcox (Oracle) <willy@xxxxxxxxxxxxx>
> ---
> mm/readahead.c | 21 +++++++++++++--------
> 1 file changed, 13 insertions(+), 8 deletions(-)
>
> diff --git a/mm/readahead.c b/mm/readahead.c
> index 15329309231f..3eca59c43a45 100644
> --- a/mm/readahead.c
> +++ b/mm/readahead.c
> @@ -154,7 +154,6 @@ void __do_page_cache_readahead(struct address_space *mapping,
> unsigned long lookahead_size)
> {
> struct inode *inode = mapping->host;
> - struct page *page;
> unsigned long end_index; /* The last page we want to read */
> LIST_HEAD(page_pool);
> int page_idx;
> @@ -175,6 +174,7 @@ void __do_page_cache_readahead(struct address_space *mapping,
> * Preallocate as many pages as we will need.
> */
> for (page_idx = 0; page_idx < nr_to_read; page_idx++) {
> + struct page *page;
> pgoff_t page_offset = offset + page_idx;
>
> if (page_offset > end_index)
> @@ -183,14 +183,14 @@ void __do_page_cache_readahead(struct address_space *mapping,
> page = xa_load(&mapping->i_pages, page_offset);
> if (page && !xa_is_value(page)) {
> /*
> - * Page already present? Kick off the current batch of
> - * contiguous pages before continuing with the next
> - * batch.
> + * Page already present? Kick off the current batch
> + * of contiguous pages before continuing with the
> + * next batch. This page may be the one we would
> + * have intended to mark as Readahead, but we don't
> + * have a stable reference to this page, and it's
> + * not worth getting one just for that.
> */
> - if (readahead_count(&rac))
> - read_pages(&rac, &page_pool, gfp_mask);
> - rac._nr_pages = 0;
> - continue;


A fine point: you'll get better readability and a less complex function by
factoring that into a static subroutine, instead of jumping around with
goto's. (This clearly wants to be a subroutine, and in fact you've effectively
created one inside this function, at the "read:" label. Either way, though...


> + goto read;
> }
>
> page = __page_cache_alloc(gfp_mask);
> @@ -201,6 +201,11 @@ void __do_page_cache_readahead(struct address_space *mapping,
> if (page_idx == nr_to_read - lookahead_size)
> SetPageReadahead(page);
> rac._nr_pages++;
> + continue;
> +read:
> + if (readahead_count(&rac))
> + read_pages(&rac, &page_pool, gfp_mask);
> + rac._nr_pages = 0;
> }
>
> /*
>

...no errors spotted, I'm confident that this patch is correct,

Reviewed-by: John Hubbard <jhubbard@xxxxxxxxxx>


thanks,
--
John Hubbard
NVIDIA