Re: [PATCH] KVM: VMX: replace "fall through" with "return true" to indicate different case
Date: Tue Feb 18 2020 - 20:40:39 EST
Joe Perches <joe@xxxxxxxxxxx> wrote:
>On Tue, 2020-02-18 at 11:39 +0800, linmiaohe wrote:
>> The second "/* fall through */" in rmode_exception() makes code harder
>> to read. Replace it with "return true" to indicate they are different
>> cases and also this improves the readability.
> return !(vcpu->guest_debug & (KVM_GUESTDBG_SINGLESTEP | KVM_GUESTDBG_USE_HW_BP));
Will do. Thanks for your advice.