Re: [PATCH 07/16] soundwire: cadence: mask Slave interrupt before stopping clock

From: Pierre-Louis Bossart
Date: Fri Mar 13 2020 - 13:28:45 EST



+/**
+ * sdw_cdns_enable_slave_interrupt() - Enable SDW slave interrupts
+ * @cdns: Cadence instance
+ * @state: boolean for true/false
+ */
+static void cdns_enable_slave_interrupts(struct sdw_cdns *cdns, bool state)

Do you want to rename this as cdns_configure_slave_interrupts, with
argument as enable/disable... ?

this follows the convention we already have with:

int sdw_cdns_enable_interrupt(struct sdw_cdns *cdns, bool state);

but it just deals with slave interrupts only.