Re: [PATCH 08/15] powerpc/watchpoint: Disable all available watchpoints when !dawr_force_enable

From: Ravi Bangoria
Date: Wed Mar 18 2020 - 03:33:10 EST




On 3/17/20 4:05 PM, Christophe Leroy wrote:


Le 09/03/2020 Ã 09:57, Ravi Bangoria a ÃcritÂ:
Instead of disabling only first watchpoint, disable all available
watchpoints while clearing dawr_force_enable.

Signed-off-by: Ravi Bangoria <ravi.bangoria@xxxxxxxxxxxxx>
---
 arch/powerpc/kernel/dawr.c | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/arch/powerpc/kernel/dawr.c b/arch/powerpc/kernel/dawr.c
index 311e51ee09f4..5c882f07ac7d 100644
--- a/arch/powerpc/kernel/dawr.c
+++ b/arch/powerpc/kernel/dawr.c
@@ -50,9 +50,13 @@ int set_dawr(struct arch_hw_breakpoint *brk, int nr)
ÂÂÂÂÂ return 0;
 }
-static void set_dawr_cb(void *info)
+static void disable_dawrs(void *info)

Can you explain a bit more what you do exactly ? Why do you change the name of the function and why the parameter becomes NULL ? And why it doens't take into account the parameter anymore ?

Before:
static void set_dawr_cb(void *info)
{
set_dawr(info);
}
static ssize_t dawr_write_file_bool(...)
{
...
/* If we are clearing, make sure all CPUs have the DAWR cleared */
if (!dawr_force_enable)
smp_call_function(set_dawr_cb, &null_brk, 0);
}

After:
static void disable_dawrs(void *info)
{
struct arch_hw_breakpoint null_brk = {0};
int i;
for (i = 0; i < nr_wp_slots(); i++)
set_dawr(&null_brk, i);
}
static ssize_t dawr_write_file_bool(...)
{
...
/* If we are clearing, make sure all CPUs have the DAWR cleared */
if (!dawr_force_enable)
smp_call_function(disable_dawrs, NULL, 0);
}

We use callback function only for disabling watchpoint. Thus I renamed
it to disable_dawrs(). And we are passing null_brk as parameter which
is not really required while disabling watchpoint. So removed it.

Thanks,
Ravi