[PATCH v3 3/6] mmc: sdhci-of-arasan: Rename sdhci_arasan_data to avoid confusion

From: Manish Narani
Date: Mon Apr 06 2020 - 13:44:30 EST


There is 'struct sdhci_arasan_data' but also
'struct sdhci_arasan_of_data sdhci_arasan_data'. Rename the latter to
avoid confusion with the name of the struct.

Reported-by: Adrian Hunter <adrian.hunter@xxxxxxxxx>
Signed-off-by: Manish Narani <manish.narani@xxxxxxxxxx>
---
drivers/mmc/host/sdhci-of-arasan.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/mmc/host/sdhci-of-arasan.c b/drivers/mmc/host/sdhci-of-arasan.c
index 34403b2..72f5d83 100644
--- a/drivers/mmc/host/sdhci-of-arasan.c
+++ b/drivers/mmc/host/sdhci-of-arasan.c
@@ -365,7 +365,7 @@ static const struct sdhci_pltfm_data sdhci_arasan_pdata = {
SDHCI_QUIRK2_STOP_WITH_TC,
};

-static struct sdhci_arasan_of_data sdhci_arasan_data = {
+static struct sdhci_arasan_of_data sdhci_arasan_generic_data = {
.pdata = &sdhci_arasan_pdata,
};

@@ -563,15 +563,15 @@ static const struct of_device_id sdhci_arasan_of_match[] = {
/* Generic compatible below here */
{
.compatible = "arasan,sdhci-8.9a",
- .data = &sdhci_arasan_data,
+ .data = &sdhci_arasan_generic_data,
},
{
.compatible = "arasan,sdhci-5.1",
- .data = &sdhci_arasan_data,
+ .data = &sdhci_arasan_generic_data,
},
{
.compatible = "arasan,sdhci-4.9a",
- .data = &sdhci_arasan_data,
+ .data = &sdhci_arasan_generic_data,
},
{
.compatible = "xlnx,zynqmp-8.9a",
--
2.1.1