[PATCH 0/3] KVM: x86: move nested-related kvm_x86_ops to a separate struct

From: Paolo Bonzini
Date: Fri Apr 17 2020 - 12:44:49 EST


Patch 3 follows the lead of the kvm_pmu_ops and moves callbacks related
to nested virtualization to a separate struct. Patches 1 and 2 are
preparation (patch 1 mostly makes some lines shorter, while patch 2
avoids semantic changes in KVM_GET_SUPPORTED_HV_CPUID).

While this reintroduces some pointer chasing that was removed in
afaf0b2f9b80 ("KVM: x86: Copy kvm_x86_ops by value to eliminate layer
of indirection", 2020-03-31), the cost is small compared to retpolines
and anyway most of the callbacks are not even remotely on a fastpath.
In fact, only check_nested_events should be called during normal VM
runtime. When static calls are merged into Linux my plan is to use them
instead of callbacks, and that will finally make things fast again by
removing the retpolines.

Thanks,

Paolo

Paolo Bonzini (3):
KVM: x86: check_nested_events is never NULL
KVM: eVMCS: check if nesting is enabled
KVM: x86: move nested-related kvm_x86_ops to a separate struct

arch/x86/include/asm/kvm_host.h | 29 +++++++++++++++-------------
arch/x86/kvm/hyperv.c | 4 ++--
arch/x86/kvm/svm/nested.c | 6 +++++-
arch/x86/kvm/svm/svm.c | 13 +++++--------
arch/x86/kvm/svm/svm.h | 3 ++-
arch/x86/kvm/vmx/evmcs.c | 4 +++-
arch/x86/kvm/vmx/nested.c | 16 +++++++++-------
arch/x86/kvm/vmx/nested.h | 2 ++
arch/x86/kvm/vmx/vmx.c | 7 +------
arch/x86/kvm/x86.c | 34 ++++++++++++++++-----------------
10 files changed, 62 insertions(+), 56 deletions(-)

--
2.18.2