[PATCH 0/3] Refactor the vnt_rf_table_download function

From: Oscar Carter
Date: Sat Apr 25 2020 - 08:39:30 EST


This patch series refactors the vnt_rf_table_download function through
tree patches.

The first one removes the local variable "array" and all the memcpy
function calls because this copy operation from different arrays to this
variable is unnecessary.

The second patch replaces the "goto" statements with a direct "return ret"
as the jump label only returns the ret variable.

The third patch replaces three while loops with three calls to the
vnt_control_out_blocks function. This way avoid repeat a functionality
that already exists.

Oscar Carter (3):
staging: vt6656: Remove the local variable "array"
staging: vt6656: Use return instead of goto
staging: vt6656: Remove duplicate code in vnt_rf_table_download

drivers/staging/vt6656/rf.c | 85 +++++++------------------------------
1 file changed, 16 insertions(+), 69 deletions(-)

--
2.20.1