Re: [RFC 02/11] net: phy: Simplify MMD device list termination

From: Russell King - ARM Linux admin
Date: Mon May 25 2020 - 04:10:03 EST


On Sun, May 24, 2020 at 09:48:55PM -0500, Jeremy Linton wrote:
> Hi,
>
> On 5/23/20 1:36 PM, Russell King - ARM Linux admin wrote:
> > On Fri, May 22, 2020 at 04:30:50PM -0500, Jeremy Linton wrote:
> > > Since we are already checking for *devs == 0 after
> > > the loop terminates, we can add a mostly F's check
> > > as well. With that change we can simplify the return/break
> > > sequence inside the loop.
> > >
> > > Add a valid_phy_id() macro for this, since we will be using it
> > > in a couple other places.
> >
> > I'm not sure you have the name of this correct, and your usage layer
> > in your patch series is correct.
>
> Or the name is poor..
>
> >
> > >
> > > Signed-off-by: Jeremy Linton <jeremy.linton@xxxxxxx>
> > > ---
> > > drivers/net/phy/phy_device.c | 15 +++++++--------
> > > 1 file changed, 7 insertions(+), 8 deletions(-)
> > >
> > > diff --git a/drivers/net/phy/phy_device.c b/drivers/net/phy/phy_device.c
> > > index 245899b58a7d..7746c07b97fe 100644
> > > --- a/drivers/net/phy/phy_device.c
> > > +++ b/drivers/net/phy/phy_device.c
> > > @@ -695,6 +695,11 @@ static int get_phy_c45_devs_in_pkg(struct mii_bus *bus, int addr, int dev_addr,
> > > return 0;
> > > }
> > > +static bool valid_phy_id(int val)
> > > +{
> > > + return (val > 0 && ((val & 0x1fffffff) != 0x1fffffff));
> > > +}
> > > +
> > > /**
> > > * get_phy_c45_ids - reads the specified addr for its 802.3-c45 IDs.
> > > * @bus: the target MII bus
> > > @@ -732,18 +737,12 @@ static int get_phy_c45_ids(struct mii_bus *bus, int addr, u32 *phy_id,
> > > phy_reg = get_phy_c45_devs_in_pkg(bus, addr, 0, devs);
> > > if (phy_reg < 0)
> > > return -EIO;
> > > - /* no device there, let's get out of here */
> > > - if ((*devs & 0x1fffffff) == 0x1fffffff) {
> > > - *phy_id = 0xffffffff;
> > > - return 0;
> > > - } else {
> > > - break;
> > > - }
> > > + break;
> > > }
> > > }
> > > /* no reported devices */
> > > - if (*devs == 0) {
> > > + if (!valid_phy_id(*devs)) {
> >
> > You are using this to validate the "devices in package" value, not the
> > PHY ID value. So, IMHO this should be called "valid_devs_in_package()"
> > or similar.
>
> Hmmm, its more "valid_phy_reg()" since it ends up being used to validate
> both the devs in package as well as phy id.

I don't think that is a valid use of the code you've put in
valid_phy_id().

--
RMK's Patch system: https://www.armlinux.org.uk/developer/patches/
FTTC for 0.8m (est. 1762m) line in suburbia: sync at 13.1Mbps down 424kbps up