Re: [PATCH] powerpc/wii: Fix declaration made after definition

From: Nick Desaulniers
Date: Tue May 26 2020 - 14:19:53 EST


On Mon, Apr 13, 2020 at 12:07 PM Nathan Chancellor
<natechancellor@xxxxxxxxx> wrote:
>
> A 0day randconfig uncovered an error with clang, trimmed for brevity:
>
> arch/powerpc/platforms/embedded6xx/wii.c:195:7: error: attribute
> declaration must precede definition [-Werror,-Wignored-attributes]
> if (!machine_is(wii))
> ^
>
> The macro machine_is declares mach_##name but define_machine actually
> defines mach_##name, hence the warning.
>
> To fix this, move define_machine after the is_machine usage.

s/is_machine/machine_is/

With that fixup, you may add my reviewed by tag.
Reviewed-by: Nick Desaulniers <ndesaulniers@xxxxxxxxxx>

>
> Fixes: 5a7ee3198dfa ("powerpc: wii: platform support")
> Reported-by: kbuild test robot <lkp@xxxxxxxxx>
> Link: https://github.com/ClangBuiltLinux/linux/issues/989
> Signed-off-by: Nathan Chancellor <natechancellor@xxxxxxxxx>
> ---
> arch/powerpc/platforms/embedded6xx/wii.c | 25 ++++++++++++------------

^ I can run Linux on my Wii...think of the possibilities!

> 1 file changed, 12 insertions(+), 13 deletions(-)
>
> diff --git a/arch/powerpc/platforms/embedded6xx/wii.c b/arch/powerpc/platforms/embedded6xx/wii.c
> index 67e48b0a164e..a802ef957d63 100644
> --- a/arch/powerpc/platforms/embedded6xx/wii.c
> +++ b/arch/powerpc/platforms/embedded6xx/wii.c
> @@ -172,19 +172,6 @@ static void wii_shutdown(void)
> flipper_quiesce();
> }
>
> -define_machine(wii) {
> - .name = "wii",
> - .probe = wii_probe,
> - .setup_arch = wii_setup_arch,
> - .restart = wii_restart,
> - .halt = wii_halt,
> - .init_IRQ = wii_pic_probe,
> - .get_irq = flipper_pic_get_irq,
> - .calibrate_decr = generic_calibrate_decr,
> - .progress = udbg_progress,
> - .machine_shutdown = wii_shutdown,
> -};
> -
> static const struct of_device_id wii_of_bus[] = {
> { .compatible = "nintendo,hollywood", },
> { },
> @@ -200,3 +187,15 @@ static int __init wii_device_probe(void)
> }
> device_initcall(wii_device_probe);
>
> +define_machine(wii) {
> + .name = "wii",
> + .probe = wii_probe,
> + .setup_arch = wii_setup_arch,
> + .restart = wii_restart,
> + .halt = wii_halt,
> + .init_IRQ = wii_pic_probe,
> + .get_irq = flipper_pic_get_irq,
> + .calibrate_decr = generic_calibrate_decr,
> + .progress = udbg_progress,
> + .machine_shutdown = wii_shutdown,
> +};
>
> base-commit: 8f3d9f354286745c751374f5f1fcafee6b3f3136
> --

--
Thanks,
~Nick Desaulniers