[PATCH 0/4] futex: Minor code improvements

From: Andrà Almeida
Date: Wed May 27 2020 - 11:47:58 EST


Hello,

This series aims to make some small code improvements that I found in
futex.c, removing some lines and trying to make the code easier to read
and understand.

All commits tested with futex tests from kselftest.

Andrà Almeida (4):
futex: Remove put_futex_key()
futex: Remove needless goto's
futex: Remove unused or redundant includes
futex: Consistently use fshared as boolean

kernel/futex.c | 115 +++++++++++--------------------------------------
1 file changed, 26 insertions(+), 89 deletions(-)

--
2.26.2