Re: [PATCH v30 08/20] x86/sgx: Add functions to allocate and free EPC pages
From: Borislav Petkov
Date: Wed May 27 2020 - 16:46:47 EST
On Tue, May 26, 2020 at 09:21:11PM -0700, Sean Christopherson wrote:
> In other words, sgx_alloc_epc_section() is poorly named. It doesn't
> actually allocate EPC, it allocates kernel structures to map and track EPC.
> sgx_(un)map_epc_section() would be more accurate and would hopefully
> alleviate some of the confusion.
> I have no objection to renaming __sgx_alloc_try_alloc_page() to something
> like sgx_alloc_epc_page_section or whatever, but IMO using get/put will be
> horrendously confusing.
Ok. My only issue is that the naming nomenclature sounds strange and
confusing as it is. "try" in an "alloc" function is kinda tautological -
of course the function will try to do its best. :)
And there are three functions having "alloc" in the name so I can
imagine someone getting very confused when having to stare at that code.
So at least naming them in a way so that it is clear what kind of pages
they "allocate" - i.e., what they actually do - would be a step in the