Re: [PATCH v3 0/4] Add seccomp notifier ioctl that enables adding fds

From: Kees Cook
Date: Wed Jun 03 2020 - 22:44:09 EST


On Wed, Jun 03, 2020 at 04:56:59PM -0700, Sargun Dhillon wrote:
> On Wed, Jun 3, 2020 at 4:42 PM Kees Cook <keescook@xxxxxxxxxxxx> wrote:
> >
> > On Tue, Jun 02, 2020 at 06:10:40PM -0700, Sargun Dhillon wrote:
> > > Sargun Dhillon (4):
> > > fs, net: Standardize on file_receive helper to move fds across
> > > processes
> > > pid: Use file_receive helper to copy FDs
> >
> > The fixes (that should add open-coded cgroups stuff) should be separate
> > patches so they can be backported.
> Patch 1/4, and 2/4 are separated so they can be backported. Patch 1 should
> go into long term, and patch 2 should land in stable.
>
> Do you see anything in 1/4, and 2/4 that shouldn't be there?

So, my thinking was to open code the fixes to minimize the code churn
in the -stable trees and isolate logical changes. However, in looking
at the commits (3.6, 3.8) and the age of the rest of the nearby code in
SCM_RIGHTS (3.7), and the actual oldest supported kernel release (3.16),
I guess it would be better to split it like you've done.

> > The helper doesn't take the __user pointer I thought we'd agreed it
> > should to avoid changing any SCM_RIGHTS behaviors?
> >
> It doesn't change the SCM_RIGHTS behaviour because it continues
> to have the logic which allocates the file descriptor outside of the
> helper.
> 1. Allocate FD (this happens in scm.c)
> 2. Copy FD # to userspace (this happens in scm.c)
> 3. Receive FD (this happens in the new helper)

Sorry, I was not writing very clearly: I was meaning to have said:

I was expecting the helper to take the __user pointer (like I thought
we agreed[1]) so we could both avoid changing SCM_RIGHTS behavior and
avoid copy/pasting of the get_unused/put_unused code in 3 places. (I
get into this more in the other thread[2]).

So, let's finalize this decision in the thread at [2]. Again, sorry I
wasted your time due to my confusion!

-Kees

[1] Apologies, I misread your "1" in [3] to be "suggestion 1" from the
quoted text from me in that email, rather than the "[1]" it was,
which was a link to your counter-proposal. And then I wasted your
time by saying "agreed".
[2] 202006031845.F587F85A@keescook/">https://lore.kernel.org/lkml/202006031845.F587F85A@keescook/
[3] https://lore.kernel.org/lkml/20200530011054.GA14852@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/

--
Kees Cook