Re: [PATCH v1 3/3] iio:adc:ltc2471: add dt binding yaml

From: Jonathan Cameron
Date: Sat Jun 20 2020 - 11:31:31 EST


On Wed, 17 Jun 2020 16:35:23 +0300
Darius Berghe <darius.berghe@xxxxxxxxxx> wrote:

> Add dt binding documentation for ltc2471 driver. This covers all supported
> devices.
>
> Signed-off-by: Darius Berghe <darius.berghe@xxxxxxxxxx>
A few things inline but basically fine.

We should however also think about documenting power supplies.
Even though the driver doesn't currently control the binding should
be as complete as possible.

Jonathan

> ---
> .../bindings/iio/adc/adi,ltc2471.yaml | 52 +++++++++++++++++++
> 1 file changed, 52 insertions(+)
> create mode 100644 Documentation/devicetree/bindings/iio/adc/adi,ltc2471.yaml
>
> diff --git a/Documentation/devicetree/bindings/iio/adc/adi,ltc2471.yaml b/Documentation/devicetree/bindings/iio/adc/adi,ltc2471.yaml
> new file mode 100644
> index 000000000000..0b84e14ec984
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/iio/adc/adi,ltc2471.yaml
> @@ -0,0 +1,52 @@
> +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
> +# Copyright 2020 Analog Devices Inc.
> +%YAML 1.2
> +---
> +$id: http://devicetree.org/schemas/bindings/iio/adc/adi,ltc2471.yaml#
> +$schema: http://devicetree.org/meta-schemas/core.yaml#
> +
> +title: Analog Devices LTC2471 16-bit I2C Sigma-Delta ADC
> +
> +maintainers:
> + - Mike Looijmans <mike.looijmans@xxxxxxxx>
> +
> +description: |
> + Analog Devices LTC2471 (single-ended) and LTC2473 (differential) 16-bit
> + I2C Sigma-Delta ADC with selectable 208/833sps output rate.
> + https://www.analog.com/media/en/technical-documentation/data-sheets/24713fb.pdf
> +
> + Analog Devices LTC2461 (single-ended) and LTC2463 (differential) 16-bit
> + I2C Sigma-Delta ADC with 60sps output rate.
> + https://www.analog.com/media/en/technical-documentation/data-sheets/24613fa.pdf

Put these two blocks in numeric order. If we end up adding a bunch more
devices it will be much more consistent if they are order.

> +
> +properties:
> + compatible:
> + enum:
> + - adi,ltc2471
> + - adi,ltc2473
> + - adi,ltc2461
> + - adi,ltc2463

Put them in numeric order.

> +
> + reg:
> + maxItems: 1
> +
> +required:
> + - compatible
> + - reg
> +
> +examples:
> + - |
> + i2c0 {
> + ltc2461@14 {

Should use a generic name
adc@14

> + compatible = "ltc2461";
> + reg = <0x14>;
> + };
> + };
> + - |
> + i2c0 {

Not a lot of point in two examples given how similar they are.
I'd just keep the one.

> + ltc2473@54 {
> + compatible = "ltc2473";
> + reg = <0x54>;
> + };
> + };
> +