[PATCH 0/6] KVM: x86/mmu: Files and sp helper cleanups

From: Sean Christopherson
Date: Mon Jun 22 2020 - 16:20:39 EST


Move more files to the mmu/ directory, and an mmu_internal.h to share
stuff amongst the mmu/ files, and clean up the helpers for retrieving a
shadow page from a sptep and/or hpa.

Sean Christopherson (6):
KVM: x86/mmu: Move mmu_audit.c and mmutrace.h into the mmu/
sub-directory
KVM: x86/mmu: Move kvm_mmu_available_pages() into mmu.c
KVM: x86/mmu: Add MMU-internal header
KVM: x86/mmu: Make kvm_mmu_page definition and accessor internal-only
KVM: x86/mmu: Add sptep_to_sp() helper to wrap shadow page lookup
KVM: x86/mmu: Rename page_header() to to_shadow_page()

arch/x86/include/asm/kvm_host.h | 46 +---------------------
arch/x86/kvm/mmu.h | 13 ------
arch/x86/kvm/mmu/mmu.c | 58 +++++++++++++++------------
arch/x86/kvm/{ => mmu}/mmu_audit.c | 12 +++---
arch/x86/kvm/mmu/mmu_internal.h | 63 ++++++++++++++++++++++++++++++
arch/x86/kvm/{ => mmu}/mmutrace.h | 2 +-
arch/x86/kvm/mmu/page_track.c | 2 +-
arch/x86/kvm/mmu/paging_tmpl.h | 4 +-
8 files changed, 108 insertions(+), 92 deletions(-)
rename arch/x86/kvm/{ => mmu}/mmu_audit.c (96%)
create mode 100644 arch/x86/kvm/mmu/mmu_internal.h
rename arch/x86/kvm/{ => mmu}/mmutrace.h (99%)

--
2.26.0