Re: [PATCH 2/8] backlight: lcd: Add missing kerneldoc entry for 'struct device parent'

From: Daniel Thompson
Date: Thu Jun 25 2020 - 05:28:35 EST


On Wed, Jun 24, 2020 at 03:57:15PM +0100, Lee Jones wrote:
> This has been missing since the conversion to 'struct device' in 2007.
>
> Cc: <stable@xxxxxxxxxxxxxxx>
> Cc: Bartlomiej Zolnierkiewicz <b.zolnierkie@xxxxxxxxxxx>
> Cc: Jamey Hicks <jamey.hicks@xxxxxx>
> Cc: Andrew Zabolotny <zap@xxxxxxxxxxx>
> Signed-off-by: Lee Jones <lee.jones@xxxxxxxxxx>

Reviewed-by: Daniel Thompson <daniel.thompson@xxxxxxxxxx>


> ---
> drivers/video/backlight/lcd.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/video/backlight/lcd.c b/drivers/video/backlight/lcd.c
> index 78b0333586258..db56e465aaff3 100644
> --- a/drivers/video/backlight/lcd.c
> +++ b/drivers/video/backlight/lcd.c
> @@ -179,6 +179,7 @@ ATTRIBUTE_GROUPS(lcd_device);
> * lcd_device_register - register a new object of lcd_device class.
> * @name: the name of the new object(must be the same as the name of the
> * respective framebuffer device).
> + * @parent: pointer to the parent's struct device .
> * @devdata: an optional pointer to be stored in the device. The
> * methods may retrieve it by using lcd_get_data(ld).
> * @ops: the lcd operations structure.
> --
> 2.25.1
>