[PATCH 0/5] devres: provide and use devm_krealloc()

From: Bartosz Golaszewski
Date: Fri Jun 26 2020 - 12:55:58 EST


From: Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx>

Regular krealloc() obviously can't work with managed memory. This series
implements devm_krealloc() and adds the first user with hope that this
helper will be adopted by other drivers currently using non-managed
krealloc().

Some cosmetic changes to the code modified by main patches are included.

Bartosz Golaszewski (5):
devres: remove stray space from devm_kmalloc() definition
devres: move the size check from alloc_dr() into a separate function
device: remove 'extern' attribute from function prototypes in device.h
devres: provide devm_krealloc()
hwmon: pmbus: use more devres helpers

.../driver-api/driver-model/devres.rst | 1 +
drivers/base/devres.c | 58 ++++-
drivers/hwmon/pmbus/pmbus_core.c | 27 +--
include/linux/device.h | 225 +++++++++---------
4 files changed, 173 insertions(+), 138 deletions(-)

--
2.26.1