Re: [PATCH v3 1/4] staging: media: atomisp: fix style of block comments

From: Rohit K Bharadwaj
Date: Sun Jul 26 2020 - 05:19:37 EST


On 26/07/20 2:42 pm, Greg KH wrote:
> On Sun, Jul 26, 2020 at 02:35:10PM +0530, Rohit K Bharadwaj wrote:
>> this patch fixes the coding style of block comments.
>>
>> Signed-off-by: Rohit K Bharadwaj <bharadwaj.rohit8@xxxxxxxxx>
>> ---
>> v3: change patch subject prefix
>> v2: split patch into sequence of patches
>> v1: fix all coding style issues in single patch
>>
>> .../media/atomisp/pci/sh_css_firmware.c | 28 +++++++++++++------
>> 1 file changed, 19 insertions(+), 9 deletions(-)
>>
>> diff --git a/drivers/staging/media/atomisp/pci/sh_css_firmware.c b/drivers/staging/media/atomisp/pci/sh_css_firmware.c
>> index d4ab15b6d1ac..2907aead98b7 100644
>> --- a/drivers/staging/media/atomisp/pci/sh_css_firmware.c
>> +++ b/drivers/staging/media/atomisp/pci/sh_css_firmware.c
>> @@ -51,9 +51,12 @@ struct fw_param {
>>
>> static struct firmware_header *firmware_header;
>>
>> -/* The string STR is a place holder
>> +/*
>> + * The string STR is a place holder
>> * which will be replaced with the actual RELEASE_VERSION
>> - * during package generation. Please do not modify */
>> + * during package generation. Please do not modify
>> + */
>> +
>
> Why the blank line?
>
Sir, I thought that it would improve the readability of the code and would help easily distinguish comments from the variable declaration part, and also since there was a blank line between the start of comment and the static struct firmware_header variable, I thought of putting a blank line after the comment end as well to maintain symmetry.