Re: [PATCH RESEND 3/5] block: Add a new helper to attempt to merge a bio

From: Baolin Wang
Date: Mon Aug 17 2020 - 23:31:04 EST


On Mon, Aug 17, 2020 at 02:24:40PM +0200, Christoph Hellwig wrote:
> On Mon, Aug 17, 2020 at 08:10:02PM +0800, Baolin Wang wrote:
> > On Mon, Aug 17, 2020 at 08:26:34AM +0200, Christoph Hellwig wrote:
> > > On Mon, Aug 17, 2020 at 12:09:17PM +0800, Baolin Wang wrote:
> > > > There are lots of duplicated code when trying to merge a bio from
> > > > plug list and sw queue, we can introduce a new helper to attempt
> > > > to merge a bio, which can simplify the blk_mq_bio_list_merge()
> > > > and blk_attempt_plug_merge().
> > >
> > > Looks sensible, but two comments:
> > >
> > > > +enum bio_merge_status blk_attempt_bio_merge(struct request_queue *q,
> > > > + struct request *rq,
> > > > + struct bio *bio,
> > > > + unsigned int nr_segs)
> > > > +{
> > > > + bool merged = false;
> > > > +
> > > > + if (!blk_rq_merge_ok(rq, bio))
> > > > + return BIO_MERGE_NONE;
> > > > +
> > > > + switch (blk_try_merge(rq, bio)) {
> > > > + case ELEVATOR_BACK_MERGE:
> > > > + merged = bio_attempt_back_merge(rq, bio, nr_segs);
> > > > + break;
> > > > + case ELEVATOR_FRONT_MERGE:
> > > > + merged = bio_attempt_front_merge(rq, bio, nr_segs);
> > > > + break;
> > > > + case ELEVATOR_DISCARD_MERGE:
> > > > + merged = bio_attempt_discard_merge(q, rq, bio);
> > > > + break;
> > >
> > > Can't we also switch the bio_attempt_*merge helpers to return
> > > enum bio_merge_status to simplify this a bit?
> >
> > Yes, will do.
> >
> > >
> > > Also I think these helpers can be marked static now, although I didn't
> > > actually apply your series, so I might have missed something.
> >
> > Cause this function will be used by blk_mq_bio_list_merge() in
> > blk-mq-sched.c, it should be exported.
>
> Shouldn't blk_mq_bio_list_merge move to blk-merge.c as well?

Yes, I can move it to blk-merge.c and rename to a generic name.