Re: [PATCH v7 30/34] i2c: tegra: Clean up variable names

From: Thierry Reding
Date: Thu Sep 17 2020 - 08:24:19 EST


On Wed, Sep 09, 2020 at 01:40:02AM +0300, Dmitry Osipenko wrote:
> Rename "ret" variables to "err" in order to make code a bit more
> expressive, emphasizing that the returned value is an error code.
> Same vice versa, where appropriate.
>
> Rename variable "reg" to "val" in order to better reflect the actual
> usage of the variable in the code and to make naming consistent with
> the rest of the code.
>
> Use briefer names for a few members of the tegra_i2c_dev structure in
> order to improve readability of the code.
>
> All dev/&pdev->dev are replaced with i2c_dev->dev in order to have uniform
> code style across the driver.
>
> Signed-off-by: Dmitry Osipenko <digetx@xxxxxxxxx>
> ---
> drivers/i2c/busses/i2c-tegra.c | 173 ++++++++++++++++-----------------
> 1 file changed, 86 insertions(+), 87 deletions(-)

That's indeed a nice improvement. One thing did spring out at me,
though.

> diff --git a/drivers/i2c/busses/i2c-tegra.c b/drivers/i2c/busses/i2c-tegra.c
[...]
> @@ -1831,20 +1830,20 @@ static int __maybe_unused tegra_i2c_runtime_suspend(struct device *dev)
>
> clk_bulk_disable(i2c_dev->nclocks, i2c_dev->clocks);
>
> - return pinctrl_pm_select_idle_state(i2c_dev->dev);
> + return pinctrl_pm_select_idle_state(dev);
> }
>
> static int __maybe_unused tegra_i2c_suspend(struct device *dev)
> {
> struct tegra_i2c_dev *i2c_dev = dev_get_drvdata(dev);
> - int err = 0;
> + int ret = 0;
>
> i2c_mark_adapter_suspended(&i2c_dev->adapter);
>
> if (!pm_runtime_status_suspended(dev))
> - err = tegra_i2c_runtime_suspend(dev);
> + ret = tegra_i2c_runtime_suspend(dev);
>
> - return err;
> + return ret;
> }

Isn't this exactly the opposite of what the commit message says (and the
rest of the patch does)?

Thierry

Attachment: signature.asc
Description: PGP signature