Re: [PATCH v3 05/11] kvm: arm64: Remove hyp_adr/ldr_this_cpu

From: David Brazdil
Date: Mon Sep 21 2020 - 10:53:26 EST


Hi Will,

> Cosmetic, but I think it would be cleaner just to define two variants of the
> macro here:
>
> #if defined(__KVM_NVHE_HYPERVISOR__) || defined(__KVM_VHE_HYPERVISOR__)
> .macro this_cpu_offset, dst
> mrs \dst, tpidr_el2
> .endm
> #else
> .macro this_cpu_offset, dst
> alternative_if_not ARM64_HAS_VIRT_HOST_EXTN
> mrs \dst, tpidr_el1
> alternative_else
> mrs \dst, tpidr_el2
> alternative_endif
> .endm
> #endif

Sure.

> (and should we have a shorthand __HYPERVISOR define to avoid the NVHE || VHE
> logic?)

Happy to add this but let's agree on the details.
* name: just __HYPERVISOR or __KVM_HYPERVISOR__?
* defined where? I'm wary of defining it in a header file because then sombody
will forget to add it and 'ifdef HYP' will be skipped. So I'd put this as
another '-D__HYPERVISOR' in the build rules. Do you agree?

David