Re: [PATCH v10 11/13] arm64: dts: freescale: sl28: enable LED support

From: Shawn Guo
Date: Mon Sep 21 2020 - 22:59:16 EST


On Mon, Sep 14, 2020 at 11:43:39PM +0200, Michael Walle wrote:
> Now that we have support for GPIO lines of the SMARC connector, enable
> LED support on the KBox A-230-LS. There are two LEDs without fixed
> functions, one is yellow and one is green. Unfortunately, it is just one
> multi-color LED, thus while it is possible to enable both at the same
> time it is hard to tell the difference between "yellow only" and "yellow
> and green".
>
> Signed-off-by: Michael Walle <michael@xxxxxxxx>
> Acked-by: Pavel Machek <pavel@xxxxxx>
> ---
> Changes since v9:
> - none
>
> Changes since v8:
> - none
>
> Changes since v7:
> - use new "function" and "color" properties instead of a label
> - added default-on trigger for the power-led
>
> Changes since v6:
> - none
>
> Changes since v5:
> - changed the label, suggested by Pavel Machek
>
> Changes since v4:
> - none
>
> Changes since v3:
> - see cover letter
>
> .../fsl-ls1028a-kontron-kbox-a-230-ls.dts | 18 ++++++++++++++++++
> 1 file changed, 18 insertions(+)
>
> diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1028a-kontron-kbox-a-230-ls.dts b/arch/arm64/boot/dts/freescale/fsl-ls1028a-kontron-kbox-a-230-ls.dts
> index 4b4cc6a1573d..dd516c0efd8b 100644
> --- a/arch/arm64/boot/dts/freescale/fsl-ls1028a-kontron-kbox-a-230-ls.dts
> +++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a-kontron-kbox-a-230-ls.dts
> @@ -11,11 +11,29 @@
>
> /dts-v1/;
> #include "fsl-ls1028a-kontron-sl28-var4.dts"
> +#include <dt-bindings/leds/common.h>
>
> / {
> model = "Kontron KBox A-230-LS";
> compatible = "kontron,kbox-a-230-ls", "kontron,sl28-var4",
> "kontron,sl28", "fsl,ls1028a";
> +
> + leds {
> + compatible = "gpio-leds";
> +
> + alarm-led {
> + function = LED_FUNCTION_ALARM;
> + color = <LED_COLOR_ID_YELLOW>;
> + gpios = <&sl28cpld_gpio0 0 0>;
> + };
> +
> + power-led {
> + linux,default-trigger = "default-on";
> + function = LED_FUNCTION_POWER;
> + color = <LED_COLOR_ID_GREEN>;
> + gpios = <&sl28cpld_gpio1 3 0>;

Use GPIO_ACTIVE_HIGH for polarity to improve the readability.

I fixed them up and applied patch #9 ~ #13.

Shawn

> + };
> + };
> };
>
> &enetc_mdio_pf3 {
> --
> 2.20.1
>