Re: Fw: [External] Re: [RFC] Documentation: Add documentation for new performance_profile sysfs class (Also Re: [PATCH 0/4] powercap/dtpm: Add the DTPM framework)

From: Mark Pearson
Date: Mon Oct 19 2020 - 14:49:33 EST


Hi

> On 19/10/2020 14:43, Hans de Goede <hdegoede@xxxxxxxxxx> wrote:
Hi,

On 10/18/20 2:31 PM, Rafael J. Wysocki wrote:
On Sun, Oct 18, 2020 at 11:41 AM Hans de Goede <hdegoede@xxxxxxxxxx> wrote:

Hi,

On 10/16/20 4:51 PM, Rafael J. Wysocki wrote:
On Fri, Oct 16, 2020 at 1:11 PM Hans de Goede <hdegoede@xxxxxxxxxx> wrote:

<note folding the 2 threads we are having on this into one, adding every one from both threads to the Cc>

Hi,

On 10/14/20 5:42 PM, Rafael J. Wysocki wrote:
On Wed, Oct 14, 2020 at 4:06 PM Hans de Goede <hdegoede@xxxxxxxxxx> wrote:
On 10/14/20 3:33 PM, Rafael J. Wysocki wrote:

<snip>

First, a common place to register a DPTF system profile seems to be
needed and, as I said above, I wouldn't expect more than one such
thing to be present in the system at any given time, so it may be
registered along with the list of supported profiles and user space
will have to understand what they mean.

Mostly Ack, I would still like to have an enum for DPTF system
profiles in the kernel and have a single piece of code map that
enum to profile names. This enum can then be extended as
necessary, but I want to avoid having one driver use
"Performance" and the other "performance" or one using
"performance-balanced" and the other "balanced-performance", etc.

With the goal being that new drivers use existing values from
the enum as much as possible, but we extend it where necessary.

IOW, just a table of known profile names with specific indices assigned to them.

Yes.

This sounds reasonable.

Second, irrespective of the above, it may be useful to have a
consistent way to pass performance-vs-power preference information
from user space to different parts of the kernel so as to allow them
to adjust their operation and this could be done with a system-wide
power profile attribute IMO.

I agree, which is why I tried to tackle both things in one go,
but as you said doing both in 1 API is probably not the best idea.
So I believe we should park this second issue for now and revisit it
when we find a need for it.

Agreed.

Do you have any specific userspace API in mind for the
DPTF system profile selection?

Not really.

So before /sys/power/profile was mentioned, but that seems more like
a thing which should have a set of fixed possible values, iow that is
out of scope for this discussion.

Yes.

Since we all seem to agree that this is something which we need
specifically for DPTF profiles maybe just add:

/sys/power/dptf_current_profile    (rw)
/sys/power/dptf_available_profiles (ro)

(which will only be visible if a dptf-profile handler
  has been registered) ?

Or more generic and thus better (in case other platforms
later need something similar) I think, mirror the:

/sys/bus/cpu/devices/cpu#/cpufreq/energy_performance_* bits
for a system-wide energy-performance setting, so we get:

/sys/power/energy_performance_preference
/sys/power/energy_performance_available_preferences

But this is not about energy vs performance only in general, is it?

(again only visible when applicable) ?

I personally like the second option best.

But I would put it under /sys/firmware/ instead of /sys/power/ and I
would call it something like platform_profile (and
platform_profile_choices or similar).

Currently we only have dirs under /sys/firmware:

[hans@x1 ~]$ ls /sys/firmware
acpi  dmi  efi  memmap

But we do have /sys/firmware/apci/pm_profile:

Documentation/ABI/stable/sysfs-acpi-pmprofile

What:           /sys/firmware/acpi/pm_profile
Date:           03-Nov-2011
KernelVersion:  v3.2
Contact:        linux-acpi@xxxxxxxxxxxxxxx
Description:    The ACPI pm_profile sysfs interface exports the platform
                 power management (and performance) requirement expectations
                 as provided by BIOS. The integer value is directly passed as
                 retrieved from the FADT ACPI table.
Values:         For possible values see ACPI specification:
                 5.2.9 Fixed ACPI Description Table (FADT)
                 Field: Preferred_PM_Profile

                 Currently these values are defined by spec:
                 0 Unspecified
                 1 Desktop
                 2 Mobile
                 3 Workstation
                 4 Enterprise Server
                 ...

Since all platforms which we need this for are ACPI based
(and the involved interfaces are also all ACPI interfaces)
how about:

/sys/firmware/acpi/platform_profile
/sys/firmware/acpi/platform_profile_choices

?

I think this goes nice together with /sys/firmware/acpi/pm_profile
although that is read-only and this is a read/write setting.

Rafel, would:

/sys/firmware/acpi/platform_profile
/sys/firmware/acpi/platform_profile_choices

work for you ?

Yes, it would.

Great. So I think hat means that we have the most important part
for moving forward with this.

So I guess the plan for this now looks something like this.

1. Rewrite my API docs RFC to update it for the new /sys/firmware/acpi/platform_profile[_choices]
   plan (should be easy and a bunch of stuff like the "type" bit can just be dropped)

2. Add code somewhere under drivers/acpi which allows code from else where
   to register itself as platform_profile handler/provider.

Rafael, any suggestions / preference for where this should be added under
drivers/acpi ?  In a new .c file perhaps ?

3.1 Use the code from 2 to add support for platform-profile selection in
    thinkpad_acpi (something for me or Mark Pearson) to do
3.2 Use the code from 2 to add support for platform-profile selection
    to hp-wmi
3.3 (and to other drivers in the future).


An open question is who will take care of 1. and 2. Mark (Pearson)
do you feel up to this? or do you want me to take care of this?

Regards,

Hans


Definitely up for (2) and will happily have a go at number (1).

If there's an example of something similar I can look at for reference that would be helpful :)

Mark