RE: [PATCH v1 1/3] vt: keyboard, use GENMAASK()/BIT() macros instead of open coded variants

From: David Laight
Date: Fri Nov 06 2020 - 10:33:44 EST


From: Andy Shevchenko
> Sent: 06 November 2020 14:36
>
> There are few places when GENMASK() or BIT() macro is suitable and makes code
> easier to understand.
>
...
> - if ((d & ~0xff) == BRL_UC_ROW) {
> - if ((ch & ~0xff) == BRL_UC_ROW)
> + if ((d & ~GENMASK(7, 0)) == BRL_UC_ROW) {
> + if ((ch & ~GENMASK(7, 0)) == BRL_UC_ROW)
> return d | ch;

Do you really think that makes it more readable?

David

-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)