Re: [PATCH] drm/mediatek: Use correct aliases name for ovl

From: Chun-Kuang Hu
Date: Sat Nov 28 2020 - 16:59:39 EST


Hi, Enric:

Enric Balletbo i Serra <enric.balletbo@xxxxxxxxxxxxx> 於 2020年11月27日 週五 下午7:02寫道:
>
> Aliases property name must include only lowercase and '-', so fix this
> in the driver, so we're not tempted to do "ovl_2l0 = &ovl_2l0" in the
> device-tree instead of the right one which is "ovl-2l0 = &ovl_2l0".
>

Applied to mediatek-drm-next [1], thanks.

[1] https://git.kernel.org/pub/scm/linux/kernel/git/chunkuang.hu/linux.git/log/?h=mediatek-drm-next

Regards,
Chun-Kuang.

> Fixes: dd8feb2262d9 ("drm/mediatek: add component OVL_2L1")
> Fixes: b17bdd0d7a73 ("drm/mediatek: add component OVL_2L0")
> Signed-off-by: Enric Balletbo i Serra <enric.balletbo@xxxxxxxxxxxxx>
> ---
>
> drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c b/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> index 8eba44be3a8a..3064eac1a750 100644
> --- a/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> +++ b/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> @@ -359,7 +359,7 @@ static const struct mtk_ddp_comp_funcs ddp_ufoe = {
>
> static const char * const mtk_ddp_comp_stem[MTK_DDP_COMP_TYPE_MAX] = {
> [MTK_DISP_OVL] = "ovl",
> - [MTK_DISP_OVL_2L] = "ovl_2l",
> + [MTK_DISP_OVL_2L] = "ovl-2l",
> [MTK_DISP_RDMA] = "rdma",
> [MTK_DISP_WDMA] = "wdma",
> [MTK_DISP_COLOR] = "color",
> --
> 2.29.2
>